ROBLOX isn't detecting some keys

:warning: (posting this for @Relaix, since I wrote it for him :warning:

(also didn’t know that someone already reported this bug, sorry about that)
NOTE: This is only about the ROBLOX client itself, keys still work in-studio, in other games, and etc…

Description:

Let me start out first by saying this “bug” just started occurring randomly. He has no clue what’s causing it but it’s very frustrating for him.

He woke up this morning and tried to play a few games on ROBLOX and realized that he couldn’t move in ANY ROBLOX GAMES.
He could only move my camera around with my mouse.

His keys work perefectly on every other game (Overwatch, CSGO, etc).

Notes:

Anytime he clicks the WASD or Arrow Keys in-game, nothing happens. Although, the WASD and Arrow keys aren’t the only keys that aren’t working.

List of keys that aren’t working:

  • WASD (only works when trying to type a chat)
  • Arrow Keys
  • ESC
  • Enter Button (doesn’t allow him to send the chat he types)
  • F1 - F12

He’s tried reseting his character in-game, and that didn’t help.
He’s tried removing and re-downloading ROBLOX multiple times, and that didn’t help.
He’s tired restarting his computer multiple times, and that didn’t help.
He’s tried connecting different keyboards, and that didn’t help.

Some Proof:

It’s almost like ROBLOX isn’t detecting my keys.
I created a little tester for @Relaix to show that ROBLOX itself just isn’t detecting his keys.
(you can visit it here to ensure it’s legit:)

Game

https://www.roblox.com/games/1408666247/tester-for-relaix

Here’s @Relaix screen:

GIF

https://gyazo.com/71587fdc20d6fe1893ae345666d608b4

Here’s my screen:

GIF

https://gyazo.com/a5cd7a779a6cd749b204657ba188b0a5

It perfectly works for myself, but not for him.

Here’s a few gif(s) showing how he can’t move in any games and only can move his camera around.

GIF

GIF

https://gyazo.com/a5a0872a72b674c684ecaf53e08f5357

You may suggest that his keyboard isn’t working, but it is. He has tested multiple keyboards and the keys are still working on all of them.

Here’s a gif showing that his keys still work:
(keyboard tester can be found here: http://www.keyboardtester.com/tester.html)

GIF

Conclusion:

Honestly, at this point we are both so lost and confused. We are basically stumped.
(if have questions or need more of an explanation, @Relaix will respond below! :slight_smile: )

EDIT: Moved to different category + replaced some GIFs with links since they wouldn’t move when uploaded/viewed)

Any help is appreciated.

Thank you.
- Vritix :heart:

19 Likes

Shouldn’t this be in the client bugs category?

This category is for abusable bugs/exploits that need to be kept private from the public community.

1 Like

Fixed, thanks for letting me know.

1 Like

Same issue here :frowning:

2 Likes

Yeah, didn’t see you posted that before creating this. :frowning:

Hopefully they get this fixed soon!

5 Likes

Same exact issue, It detects my controller input though! So I guess I can just use that for now, but no chatting with others… or playing games that’ don’t support controllers…

I’ve found my solution

It’s a bug that comes with discord. What you need to do to fix this is to go to your discord
settings, and then you go to Games and then turn off overlay for Roblox.

(If your already in a game just rejoin and it should work)

8 Likes

Experiencing the same issue; no Roblox for me until this is fixed :confused:

EDIT: Uninstalled discord and it worked again? Is this Roblox’s new way of preventing developers from using discord?

2 Likes

Are you sure you turned it of properly?

https://gyazo.com/c0282ced2e17ed5487ee4339cdddc92e

exactly when you replied i edited my message, thanks anyways!

1 Like

My friend has the same bug still.

Why would roblox stop us using discord when they use discord everyday probably?

Just for reference, it seems to be that Discord’s game overlay prevents Roblox from catching keyboard input in some cases, as Relaix also mentioned:

Given the issue only occurs with Roblox, I still do think that Roblox has something going on that other games don’t, causing this issue. But for the rest of it, I only know of Discord that has game overlays for things like Roblox - and we don’t know what changed recently to cause this issue either :frowning:

it was ment to be a joke

1 Like

Even if that happened, Why would they remove discord from people?

not sure to be honest, but some of Roblox’s action aren’t explainable either, like the recent thing with plugins

1 Like

That’s true. Oh well.

This action (luckily) is on Discord’s side

1 Like

I see.

1 Like