Roblox not launching, at all


Around 30 minutes ago I tried running Roblox; however, something very strange happened. The Roblox client refused to launch at all; Studio and the Windows App are fine, however Roblox refuses to even start. I have not downloaded any programs since the last time I launched Roblox.

I’ve tried reinstalling Roblox, restarting my PC, but nothing seems to work. It also seems other users are getting this issue. What exactly is going on here?

Apologies if this uses the wrong tags; I don’t use devfourm much.

EDIT: This is caused by Bitdefender (the antivirus). Check the solution below for how to fix the issue.


Same, I have the same issue, I have tried putting compatibility (windows 7, windows 8), and yet it still instantly closes.


I’m also having the same problem -

This is what the logs look like
Roblox failed to start client App: “FileLocation” -app, erorr code: 0, wait result: 258

Though, I’m kind of relieved I’m not the only one facing this issue


Hi! This has happened to me one time, and I did the following to resolve my problem.

Check if there are any background processes or applications that might be conflicting with Roblox. Sometimes, other running applications can interfere with Roblox’s launch. Ensure that no third-party software or processes are causing conflicts. You can check your system’s task manager to see if any unfamiliar applications are running.

^ I had almost 30-ish apps running in my background :rofl:

Hope this helps!


Nothing unfamiliar in Task Manager. Apparently, based on what others are saying, it’s the most recent Roblox build that’s causing issues.


It seems that a lot of people are having this problem. Just checked Roblox Down detector. I’m sure they’re aware and are looking into it.


I just restarted and no.
I have a clean install of windows 11. (All updated, drivers, store apps, everything)
The thing that happened to you was only you.
This is happening to alot of people.


I am currently experiencing this issue with version-faaebc838e2e45f6 on Windows 10 (19045.3570). The only reasonable conclusion is that this is an issue with the build

  1. The player executable produces no logs/dump files when failing to launch, though installer seems to produce an error. I can send the log files over to a staff member.
  2. The player executable produces no error code when failing to launch.
  3. The issue is not caused by a conflicting third party service as the issue persists in a clean boot.
  4. The issue is persistent when all local data and temporary files are completely uninstalled/erased.
  5. Studio is not affected by the issue.

I would greatly appreciate it if a staff member could acknowledge the existence of this issue as I am unable to post to bug reports and am concerned that the (relatively) small number of affected users could allow this bug to fly under the radar.


This would be the most reasonable conclusion given what little we have to work with. Doesn’t seem to be Hyperion-related either since that should produce logs/dumps IIRC.


yup same here tried reinstalling i got a updating screen and then it doesnt launch after that


hold up how do you check the logs?


i saw a few post saying Bitdefender is causing it but I’m unsure i have Bitdefender but i personally wouldn’t disable it

1 Like

Maybe. I ran a clean boot without Bitdefender so I’m not sure if that’s true. Perhaps I missed something. Regardless, it’s staying on.

1 Like

yeah if it is Bitdefender im sure a fix would be out quickly as roblox is a pretty huge game
but im getting no detection warnings or nothing

(Also happens with other avs in a vm so idk)

1 Like

This happened to me a week ago. I restarted the computer and launched it with launcherbetaexe manually. It worked. Maybe this was a random incident.

1 Like

i tried that but nothing
very strange

1 Like

i found a solution for Bitdefender users:

  1. Go to Bitdefender
  2. Go to protection tab
  3. click advanced threat defense
  4. click settings
  5. manage exceptions
  6. add C:\Users\USERNAME\AppData\Local\Roblox\Versions\version-faaebc838e2e45f6\RobloxPlayerBeta.exe (Replace Username with your username)
  7. tick the box for advanced threat defense.
  8. save and launch Roblox

(Please note you should remove this expectation after the issue is fixed.)

please reply if you have any questions


Hello starism,

Thank you for reaching out to us. From your post, I’m not sure if you are also a Bitdefender user. If so, we are currently looking into a possible incompatibility and hope to come up with a fix soon.


I was also a Bitdefender user - after I made Roblox an exception it started to work again. Seems that’s what is in common.

1 Like

Thank you for your quick reply. As mentioned, we are looking into it, but outside confirmation of the problem is always welcome and encouraged.