Roblox not loading

Roblox is not loading decals, meshes, animations, or sounds. My body doesn’t fully load and all layered clothing doesn’t load in at all.

I’ve tried restarting my router, reinstalling roblox, updating my drivers, and restarting, but nothing loads in. I have steady 60 fps and no performance issues. How do I fix this game-breaking problem? (In normal roblox player)


Did you try 1 of the following:

  • When uninstalling Roblox, clear the Roblox AppData File. (See this Support Article, under the “Delete the Roblox Folder” section.
  • Clearing your Temp files (can be done by opening Run and typing “%temp%, and deleting the files there).

I am having the same problem. I tried following the steps, reinstalling roblox and deleting the local files. No luck. I have seen previous posts about using a new IP but i am not very experienced with that sort of thing.

1 Like

For me the network wasn’t the problem and this fixed it. Can't view sponsors | Meshes and textures are not loading in | 404 on all assetdelivery api and sponsor api - #8 by NotMakos


That’s fantastic, would keep that in mind if my fixes don’t work.

Are you able to mark your own post as the Solution of this topic, so others are able to find them easily?


Actual ledgend I was worried that it wouldn’t work. Seems to all be ok now. Thanks for letting me know. :smiley:

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.