Roblox shows white screen when loading in game for a few seconds

  1. What do you want to achieve? Stop roblox from showing a white screen and stop lagging spiking when playing

  2. What is the issue? Roblox shows white screen for a few seconds then lags when loading in then lags sometimes when playing.
    image
    Video for roblox test <-------Click me

  3. What solutions have you tried so far? I have looked on the dev hub and and tutorials on youtube and they didn’t work, I am currently using the roblox app since the main app doesnt really work.

3 Likes

Did you tried reinstalling roblox client? Like full uninstall and install again. By “full uninstall” i mean that you need to go in %appdata% and other system folders and delete roblox. Thats also can be issue caused by other programms that opened when you start/launch roblox.

Thats also can be caused by ur 100% CPU usage in the video, its ok to have the white screen for like 0.1 second but the way long you have it isn’t normal

Also lag spikes sometimes cause the RAM, so i recommend you to test your pc and RAM in benchmark.

Yes I have tried to uninstall and reinstall it like you said

1 Like

I had everything closed out and just opened web broswer to open roblox, cpu was at 30% when roblox opened, roblox was below 2% most of the time the ram was also at 50% when apps were open

1 Like

Try testing your RAM, maybe its the reason? Otherwise i dont have any ideas

Can anyone else help with this issue, it happened when I just got win 11

might have something to do with your CPU usage being 100%…

As i said before, I tried with nothing open just the browser with only roblox web open and it still shows white screen with 30% cpu

Bump? character limitsssssssssssssssssssssssssss

I wonder if it has something to do with Roblox anti cheat. Make sure you have no exploiting softwares on your computer. Also is there any other applications running in the background causing lag? Check activity monitor. Also check your Roblox game settings make sure graphics quality isn’t set too high.

I have none installed, I clean installed windows, could be my gpu, ive put my gpu into my brothers pc and it worked fine tho

While doing this check the other setting in game on Roblox.

It was on the lowest setting on manual

Alright, either change it to automatic or put it at highest setting and that should fix your problem.

Sorry for long response but that didnt work for me

Have you tried doing an update on your windows 11? I know alot of people say windows 11 can be very buggy at times. Also have you turned on the new fps in Roblox?

I did try to update win 11, didnt work

Do have fps turned on in Roblox? And what brand is your pc made by?