Roblox Studio Buttons Bug?

Hi there!

So I want to work on my game, but I noticed that no matter what I do, the select/move/scale/rotate button(s) always grayed out when selected, but it doesn’t want to function as it should. I can just click all and it won’t make any differences either. (Examples are shown below)

I also wanted to point out that the game setting also does not work, I can’t open it either.

Somehow, the avatar CAN be highlighted, but the button(s) never works no matter what I did.

problem 1

I already tried to uninstall and reinstalled Roblox studio, no lucks, I can’t work on any of my games either (I can use SBS Plugin, but I can’t just rotate a certain part of the avatar I wanted, it only works with any shape parts I loaded in).
I also closed out the studio and reopened it, nothing changes either.

Yes I tried to look up too, I couldn’t find any solutions so far, unless if I somehow missed it.

Any idea how to fix this? This is affecting my time to build into games, both old and new.


I’m assuming when you click on a brick it won’t drag either, if so you might be having a dragger issue that a lot of people are having right now, take a read into this article that has gathered moderator attention, it might be of use to you, I once had this issue where I could select all toolbar options at once which seems like that’s happening to you.


To add on that, this issue can be fixed by opening the place via Studio and not by the website.


The selection plugin works smoothly. Thanks a bunch, man! :slight_smile:

1 Like

Glad I could be of assistance! :grinning:

1 Like

I was able to fix my issue via reopening studio, but some other people say they aren’t able to fix that way. though I haven’t been on studio since this incident accrued.

1 Like

yeah, I tried that twice and reinstalling it too, but it just doesn’t seem like it just solved it anyway, I don’t know if a recent update is affecting this or something because this is just an annoying (and serious) bug.

Like I said before I only had this issue once and it was solved via relaunching studio, but I have yet to use studio since this issue so it could have very well been a temporary fix. Anyhow staff are looking into the issue as we speak and it will hopefully be fixed soon enough.

I just ran into another problem, so I download it into the studio and had it in my folder but I’m now stuck on it/unable to use it? I can’t seem to run it again (I’m not sure if I should move all scripts into the server storage or something).

Not only is this a problem with the dragger but there has been a similar thread regarding (selecting multiple tools), as that seems like the issue your having right now.

In your case, there is a separate bug report similar to what your experiencing can’t ‘rotate select or scale - move ect’ a temporary fix would be disabling your user plugins staff members are aware of this known issue. If that simple method doesn’t work have you considered to toggle on ‘team create’ as that’s a solution I have used when this issue was occurring