Roblox Studio Crashes on Apple Silicon Mac

Issue Type: Crashing
Impact: Low
Frequency: Very Rare
Date First Experienced: 2021-04-06 19:04:00 (-04:00)
Date Last Experienced: 2021-04-06 19:04:00 (-04:00)

Reproduction Steps:
I simply left Studio opened and closed the lid of my MacBook Pro, putting the system to sleep. When waking up the system by opening the lid I saw a messaging stating that “RobloxStudio quit unexpectedly”.

Expected Behavior:
I expect Roblox Studio to not crash unexpectedly.

Actual Behavior:
Roblox Studio unexpectedly crashed.

Workaround:

8 Likes

The frequency that studio crashes for me is extremely high. I find that it happens most after I stop a play-test session. I’ve had this happen more than 5 times in one day. I’m running the same MacBook Pro as the original post.

2 Likes

Hello! Thanks for reporting. We’ve tried to repro the two scenarios however haven’t been able to get it to crash. Can you please upload Studio logs of instances where your Studio crashed? Please feel free to send the logs to me via DM. They should be located at:

~/Library/Logs/Roblox

3 Likes

I have uploaded log files to the private message thread at https://devforum.roblox.com/t/private-information-bug-report-from-dog2puppy/1153285?u=dog2puppy. I am not sure if these are the correct logs since there were other logs for the same day.

1 Like

It would be ideal to have logs known to contain the info required. Should the issue occur, please add logs produced at that point and Reply once more. Thanks in advance!

2 Likes

Does the crash log from MacOS provide any info?

We’ll have these looked into by the engineering team, and we’ll follow up when we have an update for you.

3 Likes

I just experienced another crash. I had closed a team create place and then tried opening my Code Templates development place. I have attached all of the related logs here. https://devforum.roblox.com/t/private-information-bug-report-from-dog2puppy/1153285/3?u=colesquared

Working as intended on my M1 Mac

I think this is more of a Rosetta problem.

Sorry for bumping, but this issue is still happening up to this day. I have a log file:

https://devforum.roblox.com/t/roblox-studio-crashes-on-apple-silicon-mac-log-file-from-localwe/1436094

For me, it just crashes for no reason. I would do something random such as closing a script, or importing something into the Asset Manager. You just got to use it for a while.

Also, here is an image of the error that I get:


I think so too.

I got more to help staff members to fix the issue. Here is the error that pops on the screen when it crashes:

Sorry, I have to use Pastebin because there is a 50k character limit.

1 Like

Still doesn’t work on my MacBook Pro either.

And you’re using an Apple Silicon Mac, right?

I don’t know what silicon means but I’m using a silver mac book pro.

Press the Apple Logo on top, than press About this Mac.
In Chip, it should either say something about Intel or Apple M1.

if it is Apple M1, this topic is right for you.

I know (Probably) the only way to fix this!
https://developer.apple.com/documentation/apple-silicon/porting-your-macos-apps-to-apple-silicon
Roblox just needs to consider reading this.

1 Like

That sounds a lot like unsolicited advice, I am pretty sure the Roblox engineers are plenty capable of supporting Apple Silicon, but it may be technically challenging/low priority/etc hence why there was no immediate fix.

2 Likes

It says:

macOS Big Sur

MacBookPro

1 Like