Roblox Studio very slow performance when window in focus


After digging around a bit I couldn’t find any relevant discussion about this. I’m having a very low framerate in Roblox Studio currently but only when the window is in focus. When it’s in the background (focus is on another window) and I drag my mouse over it the performance seems normal. It’s more or less rendering it unusable. Please let me know if there’s a way I can provide more context. I was concerned some other software may be interfering but I’m not sure where to start.

See the attached video for context:


Could you provide some microprofiler dumps, please? You can find how to do that here: How to post a Bug Report - Bug Reports - Developer Forum | Roblox

I ran a 512 frame dump for posterity; the start (up until the performance spike) is with roblox studio in the background (normal performance) and the spike/later section is with it in the foreground/in focus.

microprofile-20230703-234942.html (7.1 MB)

I had a look at the profile you attached, but unfortunately that doesn’t really point to Roblox code. It is just the present of the graphics driver (external code) that seems to be really really slow (~300ms.) You have a fairly high end machine, so that doesn’t really make sense. So more information could help.

  • Does the problem persist after restarting?
  • Are you on the latest NVIDIA drivers?
  • Is anything else running on the GPU, like for example a background process?
  • Do you perhaps have the debug layer for D3D11 enabled (it is a development thing, so if you don’t know what this is about then you don’t have it enabled and you don’t have to worry about it)
  • The problem persists after restarting (and forcing all windows updates)
  • I updated to the latest Nvidia drivers yesterday to no avail. The restart was performed after this
  • I’ve tried running with more or less no other programs running (including background processes) to no avail
  • I don’t have any DirectX debugging enabled

I did watch task manager just now whilst testing again and it almost looks like Roblox is explicitly throttling my PC performance. When in focus the CPU usage is between 0.1% and 0.4%, with the GPU between 1% and 1.8%. When not in focus CPU usage is between 0.6% and 3.7%, with GPU usage between 1.9% and 9.6% (both depending on mouse movement over the window).

I should also mention that I have reinstalled Roblox Studio and that I have a strange monitor setup (though this wasn’t an issue before) with two running at 144Hz, one at 60Hz and technically a TV turned off that I believe runs at 60Hz (if any of this helps).

Studio as a whole, really, just runs horribly now. Sometime in the past few weeks one of the updates severely hindered studio’s overall performance. There’s games of mine that now might sit for over an hour trying to load into studio, whereas before they would load within 5-10 minutes which was reasonable enough. Usually after an hour I’ve wasted my whole night and cancel the program via task manager. In the unlikely event I succeed in loading them, the in-studio performance remains very low. I think the program is just dying completely.

1 Like

I should mention that this does feel very much like some kind of deliberate background throttling being applied but in reverse (when in focus instead of when in the background). Could understand if this was flipped

It would be helpful if you have additional information about which parts are slow. Perhaps adding a microprofile will give us enough information to action this.

And you are not seeing this issue when just running the Roblox Client/Player to play experiences, right?

Correct. I don’t have any performance issues when playing a game normally at all (including the same game). The performance issues are the same when trying to play in-studio

Some extra context from some further testing. I get somewhat better (but definitely not good) performance when switching to OpenGL or Vulkan (they seem about the same). Still very choppy for both though. Up till now Direct3D11 was manually set instead of automatic (for all previous tests)

Hmm, could you grab a micro profiler capture for Vulkan?

I’m somewhat surprised the client doesn’t have the issue as it runs the exact same rendering engine code.

Yeah, this is why I was curious if it was some kind of optimisation thing for studio that’s gone haywire.

Same kind of test again. The first half is with studio in the background (whilst mousing over) and the second is with it in focus (mousing over).

microprofile-20230704-221040.html (5.2 MB)

This is puzzling. Both graphics APIs have the same behavior, but that behavior is that the graphics driver part just takes long… which is odd. We literally just call into the graphics API.

I’m somewhat stumped, so I reached out to the studio team to see if they have made any changes to throttling.

Are there any immediate things I could try? (e.g. wiping all user data locally and all hidden settings somehow)

I did try resetting all studio settings to default earlier, as well as disabling all beta features; neither of which made any difference.

I should also note that I haven’t been actively using Roblox Studio since April 21st of last year (as far as I can tell from looking at version history on my places) so this issue could have started a while back. I’ve only just in the past few days come back on to try working on some stuff. I previously didn’t have this issue. I also don’t have this issue on my laptop seemingly.

Ok, this was very much not the case previously (including yesterday I’m sure), but I am now having the exact same performance issues in games too. The following microprofile was performed the same way as previously.

microprofile-20230706-000513.html (8.0 MB)

Not having these performance issues when playing through the roblox microsoft store app. I do seem to be occasionally having chuggy performance (that feels similar) when navigating pages on there, but this is probably unrelated though

I have this same issue too.

A potential temporary fix I found was to keep a selection box of any sixe by holding down the left button and dragging your mouse a bit and then keeping the left mouse button held down.

I think it might have to do something with some viewport selection things.

Does disabling the new Studio outlines improve performance for you? You could try setting to “Bounding Boxes” as mentioned here Selection Improvements - #272 by kirazeee325

That it happens in game is interesting. I can add some extra profiling markers to hopefully further narrow down exactly where it is slow. This would come out with a release in 1.5 weeks though :sad: