Roblox throwing up HTTP 500 and Failing To Upload Union

I am currently trying to make a few changes to a game of mine. The game has around 35k parts, with a combination of unions, parts, and meshes (lots of unions). The problem is that if there are too many unions on the game (or there is a specific union that breaks) Roblox won’t allow me to publish the game, and throws HTTP 500. I tried deleting a few unions, but there is only so much I can delete before it becomes obvious and excessive.

I have tried deleting unions (which worked most of the time) and uploading a local saved copy. The local copy failed to publish because “Failed to upload union, exceeded limit”. I also tried converting some unions to meshes, but I don’t have the time to convert every little union to a mesh. I am losing my mind and I don’t know what to do. If anyone has this issue and they know a fix, please let me know, it would be much appreciated.

1 Like

Can you please search before posting? Today around 3+ topics have been made about this. Just look at #bug-reports:studio-bugs and #bug-reports:engine-bugs

I can’t find anything in those two that has something to do with my case

The point is that roblox is having issues with meshes, unions and other content uploading operations. Due to the filter not working your unions’ names can’t be moderated and so you get that error

1 Like

This was mentioned here.