Roblox Website Doesn't Work


Hello everyone, so I’m trying to login to the Roblox website. Every time I try and load it it says that there’s an internal error or Safari just straight up says it’s failed to load. This could be an issue with my Wifi blocking it, however I’ve checked and this is not the case. I’ve also check Roblox’s stats and it shows everything is operational.



  • Wifi 5G provided by AT&T.
  • Safari Specs Version 14.0 (14610.
  • Mac Specs Version 10.14.6, 2019 MacBook Air



Same thing has been happening to me for at least a couple hours today. I still can’t get in. I’m on Chrome.


The website works fine for me. I’m on Windows 10
Microsoft Edge Beta Version 89.0.774.27 (Official build) beta (64-bit).

Maybe it’s a problem with your wifi? @ProvenData


No issues here in the East Coast, for me at least. I’m going to have my tools scan the site, will update to see if it detects an issue. (Using West Coast servers).

I’m using Chrome Canary on windows 10.


No issues.

It’s fine for me, i’m on a overheating window 7. probably internet


Have you tried if Roblox works on Google Chrome?

1 Like

I’m having the same problem, they say to contact Support - Roblox but roblox is down so you cant get to that page ;-;

update: if you use a VPN it will work for some reason, I guess the roblox website is down in some places and not others.


I’m having the same issue. I’ve also had some strange secondary issues, like the one in the attached image. I can’t work in studio because I can’t load studio, nor can I load anything else on the site.


Chrome in Australia, zero issues over here.

It looks like an error on Roblox’s end, assuming its’s giving you a 500 or too many redirects on trying to get to any of the pages, but whatever is causing it is either intermittent or not affecting everyone (as shown by the handful of people here saying they’re having no issues)

1 Like

Just tried it and I’m having the same results. This isn’t due to the search browser but some sort of internal issue.


I’m guessing your Wifi blocks it for some odd reason. That has happened to me before but when I switched from Safari to Google Chrome it worked perfectly fine. Hope you get this fixed.


How could you not login into the Roblox website

I’m just about the same as @blitzahon , I use Windows, and it works perfectly well…

1 Like

I’ve actually called them to find out if this is the case; however they claim it is not.

That has happened to me before but when I switched from Safari to Google Chrome it worked perfectly fine.

Yeah this won’t work now sadly I’ve tried Chrome and Firefox in addition to Safari.

Internal error.


Windows 10, seems fine for me.
I have noticed some servers failing to join, though. Regional outage?

1 Like

Update: My phone seems to be doing the same thing on the App. The home page works just go to a group and or a players profile.


Even if this is only affecting a handful of people, this should be considered serious enough to be receiving a fix. It’ll be 24 hours since this began happening for me in a bit, and that’s ridiculous. I shouldn’t be incapable of loading the ROBLOX website.


Been having the same issue since yesterday afternoon on mobile and both of my PCs on Edge and Chrome.
I’m in Pacific United States.
Examples of issue:



Works perfectly fine for me. I reckon it might have something to do with regional servers :desktop_computer:

1 Like

The roblox website works fine for me.

I am using windows 10.

1 Like


Just checked on my iPad, the problem is persisting there too, and is only on Roblox. This is clearly an internal website problem.

I’d really like an official reply on this. Can I please use your free website, Roblox?