Roblox's dragger system has become kinda funky

Hey, I’m unsure if this is related at all but I’m having a kind of similar problem, except that I can’t do anything at all on studio, it won’t let me move (drag) parts using the select tool, won’t let me switch to move/rotate/resize and so on. One thing that I noticed is that it also wouldn’t allow me to open my Toolbox.

It has been happening since two days ago afaik, and it happens kind of once everytime I edit a new game or after me not opening Studio for a while. It fixes itself when I closed and reopened Studio. Nonetheless, it gets kind of annoying due to the fact of me having to keep restarting Studio.

Tried using studio today incase if the problem was just a one-off thing and it somehow got even worse, even less of the axis I could manipulate before stopped working, I could only move the +Z, -Z and +Y axis.

I also tested the Animation Editor and I can’t even select a rig to animate at all, I tried it on about 5 different rigs and it wouldn’t allow me to select any of them, I could hover over them, though I could with any object in the workspace. ( I am purely guessing here but I bet the animation editor’s draggers would be as broken as their ordinary workspace counterparts )

The animation editor actually relies on the draggers provided by studio. Hence, the reason why the animation editor is broken.

I suppose it was a given that they would be tied together

Yeah, it’s sort of weird that after these new looks were implemented that the draggers broke. I think it may be in correlation to one another.

My other dev had this problem, he uninstalled and reinstalled studio and it fixed itself

hi there, sorry to bother you!

But I used the dragger plugin you linked, and I had it as folder too, but I can’t seen to make it go into the plugin folders?

Sorry this sounds like a very dumb question but I have no idea how things work like this in studio LOL.

Four days later and still no difference with the tools, they’ve stayed in their same relatively broken state for multiple days on end.

Fortunately Wednesday is generally Roblox’s update day so hopefully this’ll get fixed in the process.

@tnavarts The tools works perfectly with me, but i get a lot of lag when i use them

Hey actually, after testing around I’m not entirely convinced it’s the draggers themselves that are broken, but the studio cursor.

Let me explain, so I wave my mouse around in studio for a bit and it turns into my standard computer cursor, then when I click it turns into the studio one until I move the mouse again in which case it acts as if I’ve just clicked off of studio.

This also isn’t just a me problem since I checked and other people also are experiencing this cursor change, so this may be the issue we are looking for.

( it’s worth noting also that ClickDetection in studio also doesn’t work properly with this cursor issue which just adds more fuel to this fire )

I have gotten this glitch and I can’t even move anything,rotate,resize or any of the simple tools. So now I just use an f3x builder in studio since they haven’t fixed it.

There was no REAL post made about this at the time, but the series of bugs to my knowledge have been fixed, I’ll probably keep this post here updated incase I find anything funky, but for now that seems to be fixed.

Edit: All of the default tools work just as intended, no funky behavior with the selecting, dragging or manipulating of objects found so far.

Edit 2: Ok this is so bizarre, everything works fine in most studio places, but in others the weird tool behaviors still apply. I know for a fact that it has nothing to do with the game’s settings. Here’s an example:

Bugged place

BuggedPlace

Fine place

FinePlace

I never touched the second gif’s place when the bug took place, it’s almost as if if a place got bugged then it would keep the bug after a fix was made for most places.

See my reply here: Multiple Tools in Roblox Studio Broken when Any Plugin is Enabled

The fix for this was turned on last Thursday. Let us know if you see any further problems, but we expect things to be fixed now.

2 Likes

I made an edit on the post above, a new weird place-specific thingy has started happening with it

Might the difference have something to do with how you open the places? (Team create vs local file vs cloud file)

2 Likes

This is still happening to me even still after disabling a plugin

Can you double check that you’re running the most recent version of Roblox for me?

image

1 Like

Yes,
Capture

oh hecc, yeah I think it might be the current version, my client seems to be fairly outdated.

one slight problem, I have no clue how to force a studio update so I’m just on the latest client.

Ok, I am insanely stupid and it turns out there were just a bunch of GUIs on screen that were invisible but enabled, as a result they were blocking the draggers from working properly, sorry for wasting all this time lol.

Edit: On the bright side, at least all the efforts to fixing this ‘problem’ probably weren’t completely in vein, I’m sure that it fixed some minor issues in some shape or form.

Edit 2: Can confirm that it was indeed the GUIs that were causing the issue, oopsie.

1 Like