Roblox's dragger system has become kinda funky

Not stupid at all! Most people don’t have to use the plugins folder ever if they’re just installing plugins from the toolbox. By “Plugins folder” I don’t mean a Folder instance, I mean a folder on your local file system that contains custom plugins to be loaded from local files. There’s a button to open it in the plugins tab:


I do have just one more question, and that would be how exactly do I use this instance here: image

Oh also I should probably mention that the problem persists between several relaunches of studio, I have yet to reopen studio and have the issue not be there.

That’s the source code of the plugin :smile:. You’re free to look at it if you want, but you don’t need to insert it like that.

If you put a copy of that SelectDragger.rbxm file in the folder that gets opened when you click “Plugins Folder” then the next time you open a place you should see a “Select” tool show up in your Plugins tab.

1 Like

Oh ok that makes a lot more sense now ( sometimes I can be very incompetent lol )

Now then, after using the plugin for a little bit just to see how it works and how it would effect studio it actually had some very interesting effects on the tools, somehow making them function more like how they used to and also slightly damaging them more.

Selecting was made a little more consistent, most times I would click on an object it would be selected, deselecting was made a little more consistent although there were still times where an object would be binded to my cursor with still a downright struggle to get it off again.

Moving wasn’t effected at all by the plugin aside from the selecting changes.

Scaling was very weirdly altered, it actually became possible to scale in most directions aside from the +Z axis, and obviously had the selecting changes.

Rotation and Transform ( both function pretty similarly imo ), just like earlier ( which I never provided a gif of which I probably should of ) still were as stiff as ever and unable to rotate even a fraction of a degree, I expect it would have deselected the same as the others although I couldn’t test since, again, the object wouldn’t budge in terms of rotation.

That is, selection was still not working well even when using the custom Select tool in the Plugins tab? That makes it unlikely to be a dragger problem specifically, as that Select tool is based off of the dragger code from more than a month ago (and I understand that these problems just started for you).


Yeah from what I’ve gathered this problem applies to all of the default tools ( albeit in different ways ), not just the select one. I wasn’t the only one in Gear Studio ( the group I work for ) to run into this problem earlier, Lord_Spookerz and Super3860 ran into this issue too.

Although that now begs the question of why this problem only sparked now after it wasn’t a problem in the last month. My only assumption is that a change was made in the latest 454/455 release or something or the sort, although I doubt an issue like that would have crept out of Roblox HQ unchecked.

Actually I forgot to mention this earlier, for some reason the draggers for the tools end up not properly scaling to the object, they are always insanely big, from what I’ve heard from some people anyway.

I’ve been having a similar issue where the draggers simply do not load properly upon studio startup and they become unusable.

This is the issue I’ve been experiencing. I could select multiple buttons, but none would do anything.

This is an ongoing issue with builtin plugins overall, not just the draggers. There is a fix that can be turned on soon for it.


Hey, I’m unsure if this is related at all but I’m having a kind of similar problem, except that I can’t do anything at all on studio, it won’t let me move (drag) parts using the select tool, won’t let me switch to move/rotate/resize and so on. One thing that I noticed is that it also wouldn’t allow me to open my Toolbox.

It has been happening since two days ago afaik, and it happens kind of once everytime I edit a new game or after me not opening Studio for a while. It fixes itself when I closed and reopened Studio. Nonetheless, it gets kind of annoying due to the fact of me having to keep restarting Studio.

Tried using studio today incase if the problem was just a one-off thing and it somehow got even worse, even less of the axis I could manipulate before stopped working, I could only move the +Z, -Z and +Y axis.

I also tested the Animation Editor and I can’t even select a rig to animate at all, I tried it on about 5 different rigs and it wouldn’t allow me to select any of them, I could hover over them, though I could with any object in the workspace. ( I am purely guessing here but I bet the animation editor’s draggers would be as broken as their ordinary workspace counterparts )

The animation editor actually relies on the draggers provided by studio. Hence, the reason why the animation editor is broken.

I suppose it was a given that they would be tied together

Yeah, it’s sort of weird that after these new looks were implemented that the draggers broke. I think it may be in correlation to one another.

My other dev had this problem, he uninstalled and reinstalled studio and it fixed itself

hi there, sorry to bother you!

But I used the dragger plugin you linked, and I had it as folder too, but I can’t seen to make it go into the plugin folders?

Sorry this sounds like a very dumb question but I have no idea how things work like this in studio LOL.

Four days later and still no difference with the tools, they’ve stayed in their same relatively broken state for multiple days on end.

Fortunately Wednesday is generally Roblox’s update day so hopefully this’ll get fixed in the process.

@tnavarts The tools works perfectly with me, but i get a lot of lag when i use them

Hey actually, after testing around I’m not entirely convinced it’s the draggers themselves that are broken, but the studio cursor.

Let me explain, so I wave my mouse around in studio for a bit and it turns into my standard computer cursor, then when I click it turns into the studio one until I move the mouse again in which case it acts as if I’ve just clicked off of studio.

This also isn’t just a me problem since I checked and other people also are experiencing this cursor change, so this may be the issue we are looking for.

( it’s worth noting also that ClickDetection in studio also doesn’t work properly with this cursor issue which just adds more fuel to this fire )

I have gotten this glitch and I can’t even move anything,rotate,resize or any of the simple tools. So now I just use an f3x builder in studio since they haven’t fixed it.