Root Armature in FBX does not match Imported Animation

My rig in blender has the main armature move around, and with it the respective armatures move along with the movement
(I hid all the other bones to highlight the root)

However, when I import the animation into Studio, the root does not show any movement, and all the connected bones (Limbs & Body) move as if there is no data in it

When I open the FBX back into blender it shows the animation properly, so this has to be some undocumented thing with studio

1 Like

5 days have passed, and I still haven’t figured out an answer. All solutions I found on the DevForum either don’t work or make the effect worse

There should be no reason why my FBX file is importing like this, something on Roblox’s end is causing this and I can’t pinpoint it

Could I see your export settings for exporting the animation?

Have you tried clearing all transforms?

Here’s my export settings

Roblox’s importer has some weird issue where when you import any object it makes it like 1000x larger (I have a plugin that allows me to scale it down so that isn’t a problem), and checking Appy Transform just weirds out the animation regardless of choosing FBX or Selected in the Animation Editor

dont check apply transform and turn of nla strips and all actions and turn off leaf bones

for the object types only click armature

Ok I figured out the solution and it appears it has to do with using Humanoid rather than actually importing

When I use an AnimationController with an Animator parented to it the animations import fine, albeit just scaled bigger which can be negated

For me I think just using an AnimationController and welding it onto the character should work fine, but I’m going to leave this post open in case someone figures out how to make it work with Humanoids

EDIT: It also doesn’t like it when I try to change the BasePart name so just a heads up for those who find this post


Mark it as a solution so people can find it easier

I have the same setup as your screenshot but root motion is still not there, is there anything else you did to get it to work?