RunService:UnbindFromRenderStep removed different functions with same reference name utility-focus-state-inspect-BruhMomentoBruhh 2 times

You can write your topic however you want, but you need to answer these questions:

  1. **What do you want to achieve?
    Im trying to resolve a bug where my stats are not updating when I die.

  2. What is the issue? Include screenshots / videos if possible!
    Im not sure exactly where my issue is because my output is not telling me where the issue is.

  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    Ive tried removing any renderstepped functions in the game i have so far to see if one of those functions was causing the problem but thats not it. I am using profile service to load stats into a playerData folder with various string objects, int, number, etc. when the values of these objects are changed it supposed to update the exp gui, health, etc using a .changed function.

this script only works when you first join, but after you die it wont update playerdata values anymore in serverstorage.

local part = workspace.GiveLightning
local click = Instance.new("ClickDetector", part)
local player = script.Parent.Parent

local PlayerData = game.ServerStorage.PlayerData:WaitForChild(player.Name, math.huge).Data

click.MouseClick:Connect(function(Player)
	PlayerData.EXP.Value += 1
	
	PlayerData.Bounty.Value += 10
	task.wait()
end)
4 Likes

If this is a LocalScript then it cannot access ServerStorage.

If this is a Server script then it cannot detect a MouseClick (I don’t think, anyway).

2 Likes

It is a server script in player gui. I just found out that this error is appearing no matter what game im in. Im going to try to redownload studio because its happening every time i reset.

1 Like

yeah I redownloaded studio and this bug is appearing every time i reset idk how to fix

2 Likes

It is not a bug it has to do with RBXscriptsignals and connections. Although, I do not know how to fix this but maybe use remote events to connect the client with the server.

1 Like

I don’t believe you can detect a MouseClick with a Server script:

I double-checked, there a several post on it. Here is one:

2 Likes

u can if you have a server script in player gui. the script works fine. figured out that im just getting a runservice error everytime i reset no matter what game im playing. It seems to only be games created by me. Ill get the error even if its a baseplate.

2 Likes

Update: data saving is working perfectly fine. The runservice warning will appear no matter what I do so ill just try to deal with it for now.

2 Likes

If you have reinstalled studio, then the warning is probably coming from one of your local/installed plugins.

2 Likes

Looks like it’s not any of my plugins either…

3 Likes

Disregard, I have the same warning when resetting. It’s just a bug with the CoreGui right now, but it shouldn’t be an issue (just annoying lol).

6 Likes

I was looking for a solution, all you need to do is disable this if you want it to stop showing completely.

2 Likes

note that this only is the case in studio. The warning will still appear in game (you can check by going to error reports)

1 Like

I encountered this problem as well tonight. I filed a bug report about it. You can view it here.

As others have said, it only happens when the beta feature “Updated Roblox Controls” is active. I tried it on a live game and it does not show up. So it’s specific to Studio.