"Scripting Editor" not working after latest Roblox update


So i have a scripting editor in my game and ive been getting reports that it isnt working, i only got the reports after the latest Roblox update.

It sould look something like this:

But it currently looks like this:

I also noticed that the AbsoluteSize of a Textbox is turning into “inf,26” if a frame inside that Textbox is visible but idk if that is a bug or not.

Im pretty sure that this is a Roblox problem but i cant make a bug report as im not a Regular.

If that is plugin, should tell to plugin’s creator…

not its a in game model, i can send you the model file if you want

You meant this update?

No i mean the update that was released today

after this update it stoped working

Changed the parameters and return-type of Function ScriptDocument:EditTextAsync 
	from: (string newText, int startLine, int startCharacter, int endLine, int endCharacter) -> bool
	  to: (string newText, int startLine, int startCharacter, int endLine = -1, int endCharacter = -1) -> Tuple

Looks like EditTextAsync got update and now have multiple return!
Should check what will return.

Still doesn’t have API reference sadly.

Since i have to go to bed, i’d be happy if you can go and check what is wrong
ScriptEditor_Basic.rbxm (27.9 KB)

Try turning AutomaticSize to None for the Source TextBox


That help/fixed it, it now looks like this but i’ll just edit the position

I just noticed a problem, i need the AutomaticSize as it does not scale with new lines, did Roblox break AutomaticSize's? Maybe someone can create a bug report