"Server no longer available" on teleport

Sometimes when teleporting, the user is given the following error (image taken on iPhone X)

This is detrimental to our game’s performance as the user is kicked due to something out of our control, and they may not rejoin.

Not only that - but clicking “Ok” does not do anything and only hides the dialog.


roblox has been having internet issues as of late, and i can confirm that earlier today i was having issues attributed to that aswell,
that being said,
im pretty sure there is allready a robloxcritical covering this.

1 Like

I believe this issue has been happening for quite a while, this also effects me on computer sometimes. I’ve been testing it out and I can confirm this bug is happening quite frequently and has been for a while. There’s multiple different errors for this bug like “Attempted to teleport to a place that doesn’t exist”, while the place does in fact exist, or it says something like the game is restricted.

1 Like

Yes, I’ve been getting the same thing, and I believe the leaderboards are also being effected by it too as sometimes players don’t show.



When ROBLOX is down than servers can’t even handle 5-10 players. You have a simple problem, the reason is Roblox is down and server is down as well. So, it can’t handle the progress you have, that’s why it crashes your progress and kick you out because you have over loaded progress. Even though if you have not played that game yet and kicks you out than it’s the same reason again. It can’t handle your character.
There are many many other problems regarding to ROBLOX. Some of the games has other problems i.e. Tower of Hell, when ROBLOX is down than chat in that game completely shuts down, and our cloths turn invisible or we can get simple blocky character. Let’s be aware of this because this problems is becoming visible daily.

Can confirm I have also been experiencing these issues excessively lately. It’s hard to play with any friends when a game simply fails teleportation. We end up just hopping off to a different game at that point off of Roblox.

I was just about to make a bug report on this, I cannot teleport, I was playing my own story game, and I noticed many players weren’t teleporting, I tried this myself on my own game, and I got this:

Then I went into another story game, same thing happened.

Just noticed, that this has clogged the server!
Because all the teleports are closed, because it waits until everyone has teleported, but some people haven’t teleported, so no one can play my game!

Edit: After about 5 attempts, I finally teleported!

I’m having this image
as soon as i load in my game. It doesn’t even have any teleporting. My friend is also having this issues with games such as Phantom forces and Arsenal.image I also have no teleporting scripts in my game…


This has started happening to us, as shown from this player’s screenshot:

Related: Regularly when teleporting, players are told the place is "restricted" when it is not


Users are now reporting getting this error several times in a row when teleporting, failing, joining back, and trying to teleport again.

Teleportservice is also broken for me. (My user story is I use a “softshutdown” script that teleports players to a ReserveServer and back, so they come back to an updated server automatically without pressing anything.)


Ever since release teleportservice as been notoriously unreliable. I hope this changes as I’m planning to release a game which relies heavily on this feature (as Roblox don’t seem to ever want to implement physics grids).

I’ve been getting this error reported almost every 5 minutes in my discord channel. Hope this gets fixed soon.


Glad to see this isn’t only happening to me, this has been happening in my game for a long while but it’s really been problematic recently, I’m getting tons of error reports showing teleportation failures. I don’t mean to speculate but I have noticed that these errors tend to flare up over the weekend, at least from what I’ve observed.


Similar to the other thread that was already mentioned above, this error is occuring frequently in our game too. Player counts for any similar game using teleports (basically every dungeon crawler game) seem to have dropped dramatically during the last week because of these teleport issues.

Yeah, I too have experienced this issue in my game and it’s genuinely infuriating sometimes because of my game’s reliance on TeleportService itself. When I experienced it myself I was confused about why this happened, but it was out of my power. However, I’ve only experienced this myself a couple of times, but I never had any players report it in the past few weeks.

This happens in MM2 as well, try joining your friend.

(This is an easy repro for anyone who wants to test)

I noticed that it started to happen last Thursday

Same has been happening in my game when teleporting a party of players from a lobby server to a match. There doesn’t seem to be any way to work around this, as far as I’m aware (please correct me if there is). Are we going to see a fix for this, or are we going to have to avoid designing games in the future that utilize TeleportService?

Edit: For those still looking for a decent workaround, I came up with one: When teleporting a player to another server, continuously reattempt the teleport every few seconds until the player is no longer in the server. The player will still get the error message for the initial teleport(s) failing, but they should be teleported soon after. As of writing this post, the TeleportService.TeleportInitFailed event does not fire when this error occurs, so don’t connect your teleport retry to that.

1 Like

This is still happening, and was not solved by the fixes mentioned in Regularly when teleporting, players are told the place is "restricted" when it is not - #20 if it was meant to.

Screenshot from a player today:

This reportedly happens more often the more players are being teleported.