SetCore: BadgeNotificationsActive never registered by the CoreScripts

Issue

About a month or so ago, my game became impossible to load. I have finally found that the cause of Studio hanging is from any calling of the StarterGui SetCore function to disable BadgeNotificationsActive. The call will always fail. This does not apply to any other acceptable value.

Repro

I tested this bug by running the following code in StarterGui in a LocalScript.

local success
repeat
	success = pcall(function()
		game.StarterGui:SetCore("BadgeNotificationsActive", false)
		wait()
	end)
until success

I made a place to further identify the bug that can be found here

Extra details

I have tried it in studio and in-game. It happens in both situations, the call to SetCore will always fail.

5 Likes

This issue is still ongoing and prevents developers from fully translating their games.

Hello roblox? When will this be fixed?

As far as I can tell this never worked. The documentation for this is incorrect, BadgesNotificationsActive (not BadgeNotificationsActive) is the correct SetCore parameter. I will try to get this updated on the DevHub.

1 Like

Absolutely worked in the test place! I know its a rarely used feature of the API, but its still very important for games that want to go the extra mile with translation and/or uniform UI.

The API does work, it is just incorrectly documented.

If you change the code to

local success
repeat
	success = pcall(function()
		game.StarterGui:SetCore("BadgesNotificationsActive", false) --Notice Badges instead of Badge
	end)
	wait() --This is better because the wait will actually happen, in your example the wait wouldn't happen if there was an error.
until success

it will work.

Of course, that is what I was saying. Thank you for showing the correct documentation. Also, sorry about the old code, I probably originally wrote it around 2017 and wasn’t very comfortable with pcall. The main issue was of course the incorrect documentation, and I suppose this no longer belongs under Engine Bugs?

The documentation has been corrected. Thank you for bringing it to our attention! :slight_smile:

1 Like