[SOLVED] CSG Causing malformed shapes and physics?

Having an issue with CSG, unioning even the simplest of things (Two square blocks) is causing a malformed union with strange shapes and physics or just throwing an error all together without any results.

Attached some examples of the issue, not sure if anyone else is getting this or just me. I’ve reinstalled studio twice and have re-opened the place multiple times.

I would attach a file with items that are not unioning however this is happening with every single thing I attempt to union.

I’m using the most recent version of studio on Windows 10




Thanks for reporting.

It would still be very helpful to have a simple repro case, because I currently cannot reproduce this on my own.

Is this something that started happening recently?

Started happening about 20 minutes ago, no change as of yet still replicating the same results I can shoot you a DM with a link to the place if that would be helpful?

On a side note a friend just tried to come into this same place via Team Create and when they attempted to union the same two pieces from the gif in the original post their studio crashed immediately.

This is happening to me to!

Ok, yeah. if any of you could upload a .rbxl that demonstrates the problem, it’d help me find it.
Just confirming, are you using CSGv2, or has it been disabled from file->settings->physics?

We are both using CSGv2, I went ahead and shot you a DM with some more information.

Could you tell how far from the origin the parts you are unioning are, in this case? Just a position of anything in the selection would probably help.

If I am understanding the question you are asking for the position of the two parts being unioned?

Part1: 2659.6, 74.8, -2366.1
Part2: 2707.157, 74.8, -2389.397

But this is not the only position its happening in, its happening with any parts in the game, even if I just click a single part and click union.

1 Like

Alright, we’ve disabled the most likely culprit and it helped with the local repro.

You should restart studio, try again and let me know if the problem persists.


Working fine now, thanks for the quick help!


That’s awesome.
Thanks for the help.

1 Like

Was having the same issue, reopened Studio after I saw this and everything started working again. Thanks for fixing the problem.