[SOLVED] Plugin blocked for "Misusing Roblox Systems", appeals denied

So Friday night, I tried to upload a plugin I made to Roblox which allows you to create a power grid and connect fixtures to each other. However once I made it public, it was instantly taken down for “Misusing Roblox Systems”. I appealed but it got denied, then it came to my realization that Require(ID) in a public plugin is against the TOS, (the plugin did have a Require(ID) script in a loader script that you could install via the plugin), so I removed it and updated it…

Surprise, it got taken down again, and when I appealed it got denied for a second time. I am extremely confused as I do not understand how my plugin could possibly be a violation besides that “Require” that I took out of the plugin.

Attachments:

image






1 Like

I know you’ve probably already tried but have you asked them for more context like why your plugin was banned.

wait you cant appeal something more than once

Do mod notes not get displayed there? Hm

I’m not too sure, the first time I appealed I said “This plugin and the module script it requires have no malicious intents.” but they still denied it :I

Dang well I’m looking thru ToS right now to see if I can cite anything

Found this

I looked thru ToS and it’s not really helpful, it varies based on your situation. I saw some people got banned for ban evading, audio uploading and more

Except I’m not doing any of that so I’m just as confused as you are…

1 Like

There’s not really much you can do. On the devforum they don’t handle this stuff and you’ve already tried Roblox support which didn’t work.

Idk then uh maybe wait for someone else to look into it

I re-appealed but this time on the actual Roblox Support instead of the “appeal” button on the create page. Hope this works, fingers crossed :crossed_fingers:

1 Like

Surprise… Yeah, idk what’s going on they’re not telling me anything as of why this is happening :sob:

What did you send in the support message?

You absolutely under no circumstances are allowed to use requires, it doesn’t matter what it is. Specifics such as “HD Admin” were allowed through, but otherwise you can’t do this, ever, not anymore.

i’ve been getting similar issues, it’s all due to the lines of code like require()
It’s annoying because they don’t even check it because it’s some horribly made AI that doesn’t know that there are harmless scripts there.
I hope roblox fixes this because it’s driving me insane!

I literally removed the “require” from the plugin and even after I updaded it they took it down and denied my appeal for a second time

If you obfuscated any code you’re plugin will be revoked.

I didn’t obfuscate anything, Idk how to do that and I already knew that was against the TOS.

You should’ve attached some source if you want people to find out about why it was denied.

UPDATE: “Input” used to be called “Required”, and after replacing all of them in all of the scripts and updating the plugin, it went back up with no issues. My guess is that the automated moderation saw “Required” as “Require()”. Thanks to everyone for trying to help!!


image

Solved the problem, check solution reply