Some Audios Owned by Group not working in Group Owned Game

Reproduction Steps
Bloxy Bingo - Roblox (Go into Settings > Sound > Selected Voice and select to either Jacob or Gabriel) (or play at a time where these voices are scheduled to be the default caller). The Bingo number sounds will not play.

Audios under 6 seconds long uploaded on 18/03/2022 are not playing. Longer audios work. Audios uploaded a week prior to this also work.
I can hear the sounds playing from my main account (that owns the group) but not from other accounts (and others are reporting this as an issue to me).

Expected Behavior
The sounds to play as people play the game.

Actual Behavior
The sounds don’t play as people play the game - the game introduction sounds play but not the number calls.

Issue Area: Engine
Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: 2022-03-28 00:03:00 (+01:00)
Date Last Experienced: 2022-04-07 00:04:00 (+01:00)
A private message is associated with this bug report


Hi centraltrains,

For the audio which are not working, can you visit the Configure Item page and check whether there is a permission granting Bloxy Bingo use access to the audio asset? If there is no such permission, you can create it on that page to resolve this issue.

1 Like

There is no permission for the game in the audio page, adding it works - thank you.

However, the announcement regarding audio permissions changes, stated that audios should work from group places when the audio is uploaded as a group asset (as was the case for audios uploaded before the first occurrence date), so believe this is a bug (or documentation error).

Being a bug would support the inconsistency in working with longer audios.

In my case this would mean manually changing the settings on 860 audios… please can I push for a fix rather than forcing manual labour.

1 Like

Ended up making a (rough) Python script with Selenium to somewhat automate this, here it is if anyone else has similar issues and wants to use it:

Make sure to install Selenium and place Chrome Webdriver for the relevant version of Chrome being ran in the directory of the script being ran. (1.5 KB)

To use:

  • Takes input as universe id & an array of integers as the sound ids have the universe id added as a permission.
  • Run the python script in a terminal, login to Roblox through the remote controlled browser, then press enter in terminal to start the setting process.


  • The script keeps attempting to set the universe permission, until it can read the universe id from the table of universes the audio is playable in.
  • If the universe id textbox is disabled, then it will skip that id (at the moment this will only be because “All Experiences” is disabled but it’s been said this will change in the future).
  • If Roblox gives a timeout message of “This item can’t be configured right now. Please try again later.” it will timeout and try again after 10 seconds.
  • If Roblox errors in some other way (e.g. error 400) you’ll need to paste the URL into the remotely controlled chrome browser to resume (these are printed in the terminal as progress is made).
  • Make sure to have a wide enough window (and monitor) or else the Roblox chat interface will be in the way of the save button and Selenium will error.

This has been a recent occurrence in my games too. @BuildIntoTrains is also having a similar issue. I can provide more details if necessary.

1 Like

We should not have to do this for a place owned by that group if the audio is owned by that group.This is ridiculous.

Hi, it looks like the original issue has been resolved and I will be closing this ticket. You’ll need to grant your game permission to the audio in order for it to load. We will continue to make improvements of the audio privacy system, so please be on a look out for future announcements.

1 Like

We desperately need the ability to have audios uploaded to a group work under any experience owned by that group. Having to manually whitelist every audio for every experience is tedious and error-prone.

I’d filed a feature request for this two years ago, which Seranok (who no longer works at Roblox) responded to, saying they’d have improvements for it “soon”:

1 Like

@Noble_Draconian If you/group owns both Audio and experience, permissions should automatically be granted now. Do you still face issues? Additionally, we also added ability to grant permissions from studio error messages.

1 Like


We still face issues where audios don’t work despite both the audio and the experience being under the same group. We recently added new music to our game Super Skyward Towers, and we had to manually whitelist the audios from the creator dashboard because the audios were not working in production.

The error message feature doesn’t help us, since we don’t edit our production environment in studio - we deploy to it through opencloud APIs.