Spatial Voice unable to detect output device

Reproduction Steps

Apparently the engine refuses to detect output device. You can see it when you check in-game settings.

It is very simple to reproduce, join any game with Spatial Voice enabled. Check your in-game settings.

Expected Behavior

The client detects the output device, connecting you to the Spatial Voice properly.

Actual Behavior

Spatial Voice fails to connect, missing output device.


Issue Area: Engine
Issue Type: Other
Impact: Very High
Frequency: Constantly
Date First Experienced: 2022-11-17 07:11:00 (+01:00)
Date Last Experienced: 2022-11-17 07:11:00 (+01:00)

32 Likes

Update. The Spatial Voice is connecting, but choosing output device is still not possible.

3 Likes

@Operatik do you have audio working in non voice-enabled experiences? Could you share details about your set-up (operating system, microphone, audio devices plugged-in to your computer)?

3 Likes

Audio in non-voice-enabled experiences are completely fine. It’s just that the option to choose output device isn’t exactly what I expected.

Currently, I’m using the MacBook Air(2020) with the M1 chip. The OS is the latest. Externally, I have plugged in a Blue Snowball microphone and Steelseries Arctis 5 headphones. Supposedly, in my case, I’d expect two possible output interfaces(in-built speakers or the headphones).

3 Likes

ive been having this bug happen to me as well for a couple of days now.

i’ll add that for me, updating the audio driver itself doesn’t work nor does reinstalling roblox. before this happened voice chat was working fine so i dont think it would be the input/output devices themselves causing it.
changing the settings for sound devices (setting some things to default) broke it for me, and even switching it back didn’t fix it. happened to me at 11/20

3 Likes

Been having this issue recently as well. It is 100% something to do with the missing output device as evidenced by this post, my personal experience, and a friend of mine’s experience with the issue. I’ve tried restarting my PC, turning voice chat off and on, changing output devices, and even changing headsets, but to no avail. This has been especially frustrating as there have been times when friends of mine have been using in-game voice chat to communicate, leaving me out.

Really hoping they fix this issue soon.

12 Likes

I would like to join in on this topic.

I am having this exact issue, also on a MacBook. It is a MacBook Pro 2020 (M1). I would love to hear something to try, but I have also tried all of the solutions above.

This is very frustrating, and I really hope there is a fix soon.

4 Likes

On the second thought of the title, it is more correct to say “Spatial Voice unable to change output device”. My friend has issues with their audio interfaces and has that typical headphones issue where all sounds are panned left.

3 Likes

I have this issue. I just can’t change my output settings at all for some reason. Personally, I would like to have an output setting on all games, even if it doesn’t have VC. Would be useful

8 Likes

When I join a Roblox game with spatial voice enabled, I can’t even hear my music playing in the background anymore…

It’s also just empty like OPs screenshot.

I’m using a bluetooth headset on my laptop

Hello there,

So I was recently able to solve this issue so I thought I would share what I did here. This was a process recommended by Roblox Support.

- Uninstall Roblox:

    1. Locate Roblox in your applications folder.
    1. Right-click the application, and press “Move to Trash”. Alternatively use the CMD + Backspace command.
    1. Open your trash by clicking the trash icon on your dock.
    1. Select “Empty” to empty your trash.
    1. Re-install Roblox, and try to use voice chat once again. Upon re-installation be sure to check if Roblox has access to your microphone.

I noticed that a few of you had tried uninstalling Roblox, but if you miss the empty trash step it will simply not work. I had tried this process, but forgotten to empty the trash, and it did not work.

Hope this helps anyone!

1 Like

tried this and didn’t work. couldnt work since im on windows 10 and this is probably a mac solution
i tried doing a similar thing by moving the roblox player and the roblox folder itself and emptying the trash, but it still stayed the same. good to know there is some progress on this issue though!

I am note sure if the solution provided will work on Windows, but according to what you are saying I would imagine not. My original post did not state, but should have, that it was for MacOS specifically. I apologize for the confusion!

my output device returned finally… however i dont know what fixed it as i’ve been playing roblox normally these days. im guessing an update fixed it so whoever has this problem should check to see if its fixed

it was probably today or a few days ago where it fixed itself

Look like this has returned since last Roblox Update