Stop enabling VR (Oculus) on Studio launch and Stop turning my VR setting on in game settings!

  1. Everytime I open Studio the oculus program always launches which causes a brief pause in which my PC recognizes a new display has been registered and what not. While Studio does not switch to VR view, it is still highly annoying. I don’t want to use VR in Roblox at all. Stop messing with my Oculus stuff unless I directly enable it. I hate having to unplug my headset whenever I use Roblox.

  2. I have turned the VR setting to ‘Off’ in the settings whenever I go into Roblox games and at some point its getting reset to On in between sessions. Which for me causes a LOT of freezing and lags out my entire PC as the game is loading. I can only guess this is caused by me disconnecting and connecting my VR headset.

I honestly just don’t want Roblox enabling VR at all. I don’t use it on Roblox and never plan on to.


Still an incredibly annoying issue. Its inconvenient to have to unplug my oculus headset just to play Roblox.
Can’t even turn off VR due to the amount of lag and stuttering.


Thats unfortunate and unacceptable for this to still be an issue almost a year later.
I sold my Rift until I can buy the new Oculus but this issue was incredibly annoying.