Studio acting inappropriately

The issues with studio in the past month or so are so numerous it’s not even funny at this point.

  1. You can’t open two studios at once anymore. Me and many of my friends have tried to open two studios at once. Instead, the viewport of the 2nd studio becomes ANOTHER studio tab, and the entire 2nd studio place just becomes unusable entirely. Forcing you to close the first one and reopen the second.

  1. Somehow if you select 5-6 UI elements and try to move them… it deselects one of them and only moves the rest. This has been a constant issue for years now and it has not been fixed at all.

  2. Theres random issues like this (UI visibility button not available) which is horrible because I encountered this as well and I was forced to restart studio to fix it MULTIPLE TIMES.

  3. Oh wait, then there’s just simple usability issues, like having to hit the “refresh” button the studio games page to actually get it to load all your games.

  4. Adding this after I posted because I just found this. I deleted a script I was working in and it GOT STUCK on the viewport.

The toolbox does not even properly load.

    I opened a local server in studio with TWO players. This happened multiple times, and I had to restart my studio multiple times to fix it.

  2. New bugs are just coming at me like that.
    roblox studio broke - YouTube
    It does not show in the video, but for me, the viewport (map) becomes fullscreen,and I cannot get out of it, then it further proceeds to crash studio.

EDIT: The issue was the device emulator, i closed it and the bug fixed… Issue? I can’t reopen it now, it’s completely broken. Meaning I cant see if my UI is scaled or not without going ingame.

  1. This isn’t a bug instead a general complaint of a feature that is so basic that it is a shame on Roblox that it hasn’t been added. Zooming in on UI…

On top of it all, I don’t even have the LEVEL to post the first two in bug reports… which is stupid and causing me to rant here.

So… if someone could please post the first two points in bug reports for me, it would be greatly appreciated.


Also have been having this issue for some time now, its possible to get 2 studios open if you just keep closing and reopening the new tab over and over until eventually it works, it can take 15 minutes to work sometimes.

Average billion dollar company who can’t even make a workable user experience.


It’s 2013 all over again…And I wasn’t even ON the platform in 2013!


Personally haven’t experienced the 1st issue; I’m able to run 2 different studio tabs at once. I open up the desktop icon twice instead of the pinned shortcut.

For the second issue, are you talking about selecting gui objects from the screen, or from the explorer? I always select my gui objects from the explorer.

Not to mention the search bar in the “my models” tab doesnt even work. whatever they did with the audio update absolutely ruined my games. they mute all of my original audio now but will let me use a tool box audio that was clearly stolen from fortnite lol


The search bar barely yields any accurate results anymore. It’s very inconvenient for me.


Selecting from the screen is just broken overall and glitchy, so yes I select from the explorer. When I select 5-6 items, sometimes it only moves 5 of the items and completely ignores the 6th one i had selected.


Docking was also broken (completely) a week ago. Thankfully, the reset docking button exists.

1 Like

This is (kind of) irrelevant but:
I just got a new GPU and all my apps work faster. Studio, however, is slower…


I’m 49.99% sure the my models tab is broken as well. I frequently cannot find models that I KNOW I own in there.



I share in your issues.


Heres a new issue, the toolbox doesnt even load… AT ALL

You mean the times when audios had a memory leak whenever you played them? Good times.

Have you and your friends perhaps tried this:

The solution to the docking problem was to resetview. This did not fix the multiple windows problem.

I don’t suppose you know how to fix this then?

context: I opened a local server with TWO players. It wont let me open one anymore without it doing that…

you and your friends

I don’t have very many friends that use ROBLOX Studio, so I’m kind of the only one experiencing this.

Other users have had this problem. For some of them, deleting the key worked for them. For others, they needed to enable the High DPI beta. I’m not sure if either of these apply to you.

I have found yet another roblox bug pertaining to the viewport.

I now cannot enter studio without this bug happening, so this is a complete fully studio breaking bug.

When I enter, if i try to close one of my docking tabs, the viewport (the game map) fullscreens and I can’t get out of it. It then proceeds to crash.

I don’t know why it doesn’t show the video doesn’t show the viewport becoming full, but that is how it shows for me and theres no way out of it.

You may be asking how I’m going to use studio now, well cross your fingers because I’m currently trying to reinstall it. (for the second time in two weeks)

EDIT: uninstalling didnt work, if anyone knows something i could do please let me know. Otherwise, someone please report this, I can’t use studio until its fixed.

Did you try to delete the registry key again after this started happening? In the thread where others have had issues with this new overhaul, which has been out for several months now, this has fixed the issue for them.

Refer to this post:

If this doesn’t work, post in either of the threads linked, describing your issue.

Right yeah that didnt work but I did find the issue.
The device emulator was bugged and causing this. I closed it and reopened it to fix it.