Studio CollisionFidelity broken while building/placing Meshparts

I’ve noticed this problem while building, when trying to place Meshparts on Parts
If the Collision Fidelity is set to Default/Hull the Meshpart will sit 0.05 studs off the surface of the part
and will be slightly offset, however this problem is fixed and soon as the Collision Fidelity is set to box.!

Here is a photo to better explain this bug.

Here is the place file re-creating the bug.
Collision.rbxl (17.6 KB)


Please review:

Attach what you have there in the screenshot as a .rbxl/.rbxm. Always include a repro file when possible.

Yes I’ve have read that and not alot of that applies to this bug.
I’ve explained it the best I can.

1 Like

I have had this issue before.
Had to turn off collisions because of it.