Studio crashes 100% or 'failed to bind to workspace'; also cannot play any Roblox game

The bug(s) in question - description
When opening a place in studio (any place), it either crashes 100% of the time with the standard crash message and the place cannot be accessed, or it mysteriously says that plugins failed to load and all the standard studio menus appear, but the game viewer cannot be used to see the game (blind), and upon closing studio, it states that it ‘failed to bind to workspace’

With this, I also discovered that I can also not play any Roblox game at all, resulting in a completely white screen when trying to play - or sometimes I’m greeted with a half-loaded skybox accompanied by a freeze shortly after.

The bug started happening today, and last night it worked fine. I already tried restarting my PC and reinstalling Roblox Studio, none of which resolved the issue.

I’m sure this is a PC problem, as my brother’s computer works fine.

Snapshots of the bug(s)
image


At opening place bar hitting 100% it just remains black and pops open the generic crash text. A new dump is created after each attempt.


When trying to play any game, the screen is just white and nothing happens, clicking the window makes it not respond.

System Info
CPU - Intel® Core™ i7-6500U CPU @ 2.50GHz
Memory - 8.0 GB DDR3
GPU 0 - Intel® HD Graphics 520
GPU 1 - NVIDIA GeForce 940M

Dump Files
https://devforum.roblox.com/t/dump-files-logs-studio-crashes-100-of-the-time-cant-play-any-roblox-game/458150

My guess is that it has to do with my graphics driver of some sort, as I updated some of the drivers.

More info:
So today, I decided to check how things are working and found that heavier games crash me faster than those that are simple to load. While I cannot say for sure the rate at which I crash on the low-end game, I can confirm that within the first 30 seconds on the high end game the client just freezes and forces me to force close the game. Earlier I couldn’t even get into the game, freezing when the skybox is loading, and sometimes I get the general failure error.

As far as studio, it appears to do something similar in that studio crashes in a studio that is filled with more parts, models, etc.

2 Likes

Can’t confirm, de facto, I just clicked off a game and was in studio like 20 minutes before I got in the game. Everything works perfectly fine for me.

Its a pc problem so I provided my dump files and specs so they can help me troubleshoot it.

I was also experiencing this issue. Disabling the NewLuaTypeChecking beta features worked for me.

I have also been getting the “Failed to bind to workspace” error whenever I try to playtest in Studio.

I dont have that enabled, unless it is enabled automatically? Where can I check?

File -> Beta Features

Disabling beta features and then trying again may help.

You see I don’t have beta features enabled and I can’t even get that far into studio without it crashing.

I’m having some of the same issues, except for me it has been happening for a couple months now to some extent (though not this badly). It also seems to only happen for me whenever I press the “Play” button in studio or when I go in game.


Sometimes my studio will sort of freeze up and I can still resize the widgets, but it causes this to happen.

A lot of the times, it results in my computer blue screening.


My System Info
Intel® Core™ i7-5500U CPU @ 2.40GHz
12 GB RAM
Intel® HD Graphics 5500
NVIDIA GeForce GTX 850M

Windows 10 Home (10.0.18362)

Just started encountering this same issue whenever I try loading places up.
Appears as this instead of the place itself.


Shows this upon closing studio.
image

Can confirm this is replicating with me as well

Same issue here,

1 Like