Studio Crashes Breaking and Preventing Login

I am sick and tired of this happening because it makes absolutely no sense.

Everytime my studio gives me a crash error, usually when stopping a game or being in mid-development I am no longer able to login at all.

image

Now I do this, and it sends me to the browser login, which also does not work.

I have to delete all local app files, and then uninstall studio, it will then fail to login again, send me to browser, then work.

This will not work UNLESS I delete the local files first, before uninstall.

I have to deal with this at least once a day.

Here is my report as of right now:

Crash:

1558243350.67065,0990,7 NetworkServer:Stop blockDuration(1000)
1558243350.72070,0990,7 NetworkServer:Destroy
1558243350.91724,0990,6 Error: Adding plugin window failed with error: Unable to create DXGI swapchain: 887a0005
 Your plugin windows may not work correctly. Please close and reopen the place to restore plugin window functionality. If this problem persists, please contact Roblox customer support.
1558243350.92139,0990,6 Error: Adding plugin window failed with error: Unable to create DXGI swapchain: 887a0005
 Your plugin windows may not work correctly. Please close and reopen the place to restore plugin window functionality. If this problem persists, please contact Roblox customer support.
1558243350.92334,0990,6 Info: 		RobloxViewStudio::RobloxViewStudio - start
1558243350.92334,0990,6 Info: 			Marshaller
1558243350.92334,0990,6 Info: 			BindToWorkspace
1558243350.92334,0990,6 Info: 		RobloxView::RobloxView - end
1558243350.92334,0990,6 Info: 		RenderScheduler::RenderScheduler - start
1558243350.92334,0990,6 Info: 			Marshaller
1558243350.92334,0990,6 Info: 			BindToWorkspace
1558243351.72314,42d0,6 Info: StartProcessException...

1558243495.04138,3060,6 

Command line:
C:\Users\Court\AppData\Local\Roblox\Versions\version-3dfc7aa4bd684cc0\RobloxStudioBeta.exe -startEvent www.roblox.com/robloxQTStudioStartedEvent

Attempting to Open Studio

1558243495.04138,3060,6 Finding AppSettings.xml
1558243495.04138,3060,6 Opening AppSettings.xml
1558243495.04338,3060,6 Parsing AppSettings.xml
1558243495.04438,3060,6 Looking for 'Settings' element in AppSettings.xml
1558243495.04438,3060,6 Looking for 'ContentFolder' element in AppSettings.xml
1558243495.04538,3060,6 Looking for 'BaseUrl' element in AppSettings.xml
1558243495.04538,3060,6 BaseUrl loaded from 'AppSettings.Xml'
1558243495.04838,3060,6 Looking for 'IsScriptAssetUploadEnabled' element in AppSettings.xml
1558243495.04838,3060,6 Looking for 'IsAnimationAssetUploadEnabled' element in AppSettings.xml
1558243495.04838,3060,6 Looking for 'IsImageModelAssetUploadEnabled' element in AppSettings.xml
1558243495.04838,3060,6 Looking for 'CrashMenu' element in AppSettings.xml
1558243495.04938,3060,6 fetchClientSettingDataViaHttps
1558243498.95816,3060,6 LoadClientSettingsFromLocal group: "ClientAppSettings"
1558243498.95816,3060,6 LoadClientSettingsFromLocal group: "StudioAppSettings"
1558243498.95916,3060,6 CrashReporter Start
1558243498.95916,0b90,6 WatcherThread Started
1558243499.59375,3060,6 Uploading 1 crashes to Backtrace
1558243499.59575,2f24,6 Uploading C:\Users\Court\AppData\Local\Roblox\logs\log_132BE 0, 385, 0, 303034.RobloxStudio.dmp to https://upload.crashes.rbxinfra.com/post?format=minidump&token=8608fce9cad86072eee36b7d1d9dc56d68101a6b1f783c7bf568d80972ee1837&PlaceId=2513984680&PlayerId=21991419&DatacenterId=0&ServerIp=localhost&IsVIPDeveloper=false&AppVersion=0%2E385%2E0%2E303034&PlayTime=4013&UsedMemory=1065189376&BaseUrl=www%2Eroblox%2Ecom&IsTainted=false&UniqueId=6928616541856406551&Is64Bit=true
1558243499.61074,3060,6 systemLocale.name() = en_US
1558243499.66317,3060,6 Info: RobloxMainWindow::RobloxMainWindow - start
1558243501.52340,3060,6 Info: RPC:Constructor Started server - RBX_STUDIO_14708
1558243501.52340,3060,6 StudioABTests using browserTrackerId 41067889467
1558243516.05928,3060,6 setAssetFolder C:/Users/Court/AppData/Local/Roblox/Versions/version-3dfc7aa4bd684cc0/content
1558243516.06128,3060,6 Reflection::load C:/Users/Court/AppData/Local/Roblox/Versions/version-3dfc7aa4bd684cc0\ReflectionMetadata.xml
1558243516.88861,3060,6 Info: RobloxMainWindow::showNativeLoginPageWidgets
1558243516.90675,3060,6 ======== Studio Startup Times =======
1558243516.90675,3060,6 FastFlagsLoadTime  : 3.9168 sec
1558243516.90675,3060,6 Authenticated : NO
1558243516.90675,3060,6 LoginPageOpenTime  : 21.8761 sec
1558243516.90775,3060,6 Info: RobloxMainWindow::RobloxMainWindow - end
1558243524.12273,3060,6 Info: RobloxMainWindow::closeEvent
1558243526.00459,49fc,6 Error: Unable to authenticate user. Request timed out.
4 Likes

Hi TechSpectrum,

That sounds very frustrating. We have logged the issue in our bug tracker. We have unfortunately never seen this problem in the office which makes it hard to fix.

You are right that it does not make sense that you have to delete the local files and uninstall Studio. Have you tried just deleting the cookies in the Windows registry? They’re stored in HKEY_CURRENT_USER/Software/Roblox/RobloxStudioBrowser.

Thank you for reporting the issue,
MakerManMac

Just tried it, still doesn’t work.

I want to say maybe even though it crashed a service is still running but even restarting my PC doesn’t help.

Are you running any anti-virus, and if so have you tried disabling it?

I have malware bytes for over a year and never had an issue with it. This was recent.

This is also happening for me. Incredibly frustrating. I get this every time I run Play Solo from Studio. Logging in from the website does work for me, but only for a little bit.

I’m not entirely sure it’s the same issue though, so I’ve made another thread for it too:

1 Like

I recommend disabling malware bytes temporarily and see if the problem goes away. We haven’t heard of any other users with this problem, and we have had odd issues with anti-virus in the past.

The issue Crazyman32 has sounds like a different problem. It is most likely an intermittent connection problem.

Last Scan was 68 days ago, no, it is not Malware Bytes.

This happens for me too when I get logged out of Studio, only way I can get back in is opening Studio via the Roblox Website

This might be related to the OP;

Every time I turn on my computer and open Roblox Studio it would say that it can’t login because of “no internet connection”, but after a few seconds it logs me into the place anyway and then my Username is “Unknown” shown in the Username tab on the top right

This started happening about a week ago.

More info on my workflow,

I like to work offline save files Locally so I don’t open my games from the website using the Edit button unless I need to,

after I log into Studio once with that error I can’t login again it will ask for my Username and Password so I open a game (any game I have access to) to make it connect, the first time it would be stuck on the loading screen so I close it then open the game again then it would work fine most of the time until I turn off my PC.

Something has happened to me recently, I have been logged out of my account for no reason, this happens on a regular basis when I reopen studio. Maybe this is linked?

1 Like

ROBLOX Studio has had many issues with the login interface for the past few months.Once I changed the password of my account and after I did so and tried opening studio, it told me to login (obviously). And after I entered the correct information (I double checked and this is not the only time this has happened to me) it told me that I had tried to login too many times from my network and told me to login on ROBLOX’s website. The last time I had been asked for my password on ROBLOX Studio was probably months ago.

1 Like

The exact same thing has happened to me.

1 Like