Studio crashes when I try to open any place

I am on a Mac. After Roblox Studio attempted to update and failed, when I try to open any place (local file/Team Create/Edit from the website) Studio instantly crashes.

What happened:
I had one Studio window open in a Team Create.
I opened a local file, opening a second Studio window.
The new window instantly closed telling me that an update was available. I think the first window also closed at this time.
The update progress bar appeared, and seemed to update fine… then a second update window appeared.
The first update window indicated the update was successful.
The second update window continued for a couple seconds, then displayed an error message.
It said that updating failed, and mentioned “boost::” but I can’t remember the entire error unfortunately.

At this point, I tried launching Roblox Studio but it wouldn’t even launch. I uninstalled Studio by deleting the applications Roblox and Roblox Studio, as well as NPRoblox.plugin. I restarted then downloaded and installed Roblox Studio from the web, which now launches, but cannot open any place files. I tried moving all com.roblox… files from ~/Library/Preferences out of the folder and relaunching, but the issue persists. I didn’t find any further troubleshooting steps available on the Roblox help site, so I need your help to figure out what to try next. Thanks.

It may be worth noting that even after I removed the preference files, when I relaunched Studio, it was still in Dark Theme, which implies there may be more pereference-related files that I have not found & removed.

2 Likes

Can you reproduce this error and take a picture of the error?

1 Like

No, the error occurred only once as a result of the strange double update behavior. After the update failed, I reinstalled Studio from the internet, so it is not trying to update itself now. It launches fine, and then when I attempt to open a place, the window disappears and the application quits without any message at all.

I don’t see this affecting everybody, ROBLOXCRITICAL is not appropriate.

I can’t reproduce it myself, anyways.

I will remove it from the title.

I didn’t interpret this as anyone can reproduce it, I interpreted it as it errors fatally for me 100% of the time when I follow the steps. I am not trying to abuse the system, I need help fixing this because it stopped my workflow completely. I have already had multiple setbacks including the GPU on my main PC failing and needing to be replaced.

Related?

This was ROBLOXCRITICAL as it had a 100% reproducible crash that drastically impacted workflow (you couldn’t open places).

It looks like the issue should be solved once you re-install though.

3 Likes

The issue you mentioned above has been resolved with the most recent update (at least for me).

1 Like

Ok thank you, I just tried it and it works perfectly! Thanks for the prompt help!