Studio Crashes When Opening The Object Browser and What's New Menus While Editing Place

As a next step to those still experiencing the freezes on insert object/whats new window opening, or script saving. Could you please make sure your NVIDIA Drivers Download The Latest Official GeForce Drivers are entirely up to date?
And possibly let us know what your current driver version is
NVIDIA Driver Help|NVIDIA UK (How can I find out what driver version I have?).

2 Likes

As stated above, this is not the issue I am having. There are no missing DLL files. This is for a different issue.

Update #2

I do see that some people are confusing this issue with another issue of a missing .dll file. This is not the case in this situation. Read above for more information.

1 Like

I just found a way to avoid this bug but i dont know if it work for everyone i open a place which is a rbxl file it everything works completely fine i can open object browser with any method without crash but when i open a normal place that is not rbxl file it crash every time i try to open object browser

1 Like

In my video, I opened an empty file and it crashes. I also made sure to test with my local files (.rbxl and cloud) when experimenting and it had the same issues.

1 Like

I’m still experiencing this issue - my drivers are up to date.
Driver Version: 516.94

1 Like

I’ve been experiencing issues for about a week. When you open normal studio, it freezes/shows a white screen. As @Purasia mentioned, after reinstalling Studio/restarting pc, studio temporarily works. While in that temporarily working state, Studio is slow/crashes occasionally. Once studio is closed then re-opened, it stops working.

What I’ve attempted (and what hasn’t worked):

  • Fully updating all drivers/making sure Windows is up-to-date
  • Reinstalling Roblox Studio & Roblox Player (multiple times)
  • Using Device Manager/Task Manager (a LOT of trouble shooting)

Device Specs
Processor - 11th Gen Intel(R) Core™ i7-11700F @ 2.50GHz 2.50 GHz
Installed RAM - 16.0 GB (15.7 GB usable)
System type - 64-bit operating system, x64-based processor

Windows Specs
Edition - Windows 11 Home
Version - 21H2

3 Likes

I don’t know if anyone else is experiencing this, but in team create committing scripts also crashes it for me. Edit: just checked and, yes some other people can’t commit either. This was already harmful but not being able to commit scripts is even more harmful for the people whos job is development, hope it gets fixed soon.

On another note, my studio has started and stopped doing this multiple times now, and today it started again and it hasn’t ended. Before that it’d stop working for only like 20 minutes but now it’s been ~7hrs and still hasn’t randomly started working for me.

2 Likes

Update:
I found that disabling team create allows you to continue working on scripts without the risk of studio crashing.

2 Likes

I was experiencing the same problem. The solution was to update my graphics card drivers

1 Like

hey, i got the issue as well, yesterday o launched studio for the first time since the UI update and ran into this

1 Monitor
Nvidia GTX 850M
Windows 10 home
Asus

1 Like

Welp, studio had finally pushed another patch which I was to assume would’ve fixed this issue, however it did not, and instead it just took me off the beta branch again and put me back into the crashing one. Splendid.

2 Likes

Studio just updated back to the ‘new and improved’ inaccessible icons at the time of this post.
If I try inserting something, studio crashes (meticulous quality assurance)

This is a fresh installation on a fresh computer of both Client and Studio.
Context:
I had to destroy everything because of the Update 280 error I got attempting to disable the equally unwarranted InApp, said error still persists for just this Roblox account, not even specific to browser.

3 Likes

Platform & Spec:

Manufacturer/ Model:

MSI GS76 Stealth 11UG-232

Specs:

OS: Windows 10 Home (fresh installation, fresh installed drivers from OEM)
CPU: Core i9-11900H @ 2.5 - 4.9GHz
Chipset: HM570
GPU: NVIDIA® GeForce RTX™ 3070 Laptop GPU (fresh installed drivers)
Video Memory: 8G GDDR6
Memory: 32GB (16G*2) DDR4 3200MHz
HDD Capacity: 1TB NVMe SSD (Interface: NVMe )

Full Source: MSI Website (see MSI GS76 Stealth 11UG-232)


Multiple Monitors (Laptop, HDMI cable to Samsung C24F390


This is only with the new icons. They went away but just got brought back

1 Like

I just tried this. It worked. I can now see the Ctrl + I menu without crash.

Thumbnails in startpage do appear black. File new > open a place, things did not freeze.

1 Like

I got the “patch” today on my main, and it now crashes again. However, I can thankfully use the Roblox player now. I’d rather wait until a patch is done so I can still play Roblox.

I have tried everything on the new version that normally would crash and there is absolutely no difference. Something definitely is incompatible with this version as the object menu does open but crashes when it tries to load.

Solutions I tried:

  1. I’ve made sure that I am on the most recent version of Windows 11.
  2. I updated my graphics card drivers.
  3. I did a clean install Roblox Studio.
  4. I’ve replaced .dll files to ensure that they were the most recent versions or to ensure that they weren’t corrupted.
  5. I have made sure to have all of my plugins disabled when testing. None of them were causing the crash.

Nothing seems to be working, no matter what I tried. Roblox Studio would only crash on the version with the new icons, as I tested when I was brought back to a stable version (which, I don’t want to do again since I couldn’t use the Roblox player).

Things I noted during the crashes:

  1. All crashes don’t have the “An unexpected error occurred and Roblox needs to quit. We're sorry!” pop-up.
  2. Roblox Studio doesn’t have any issues with CPU, GPU, or Memory according to task manager.
  3. A white box shows up when opening the InsertObject menu from the context menu or the + button.
  4. The ribbon menu object browser opens up, but can’t load at all and immediately crashes.
  5. The What’s New menu doesn’t even have a chance to load at all, but works perfectly fine in the start menu.
  6. All these issues have started happening with the new icons update. It has never had any issues in the past.

I have been testing if any other methods are a problem and ensuring that everything can be worked through.

3 Likes

My studio got updated back to the version where I keep crashing trying to insert an object, just like @sinistersecret02 , @MrGreystone and @hunterk1241 have stated above. The patch seems to have done nothing but revert me from the beta branch to the broken version.

3 Likes

Studio still isn’t working. It worked the first few times I opened it, then suddenly froze. Once I shut it down and opened it again, Roblox studio wouldn’t respond. The games never loaded - just a white screen.

Dual monitor, same specs as my reply above.

What studio looks like when I try to open it

If I could be reverted to a previous version, I would appreciate it @PoshKiwi.

1 Like

I have been reverted back to the new unstable build and based on what previous people said, I assume this is the patch that was meant to fix things. However, the opposite has happened and nothing changed from when I originally reported this issue. Could I be put on the old build again while this is fixed? @PoshKiwi .Thanks!

Also my nvidia drivers are on version 516.94 (the latest).

1 Like

It still crashes when applying script edits or the inert object menu is opened. It’s been 10 days!

Highly likly at this is due to the new Roblox Desktop update. Run studio as administator