Studio Crashes When Opening The Object Browser and What's New Menus While Editing Place

It still crashes when applying script edits or the inert object menu is opened. It’s been 10 days!

Highly likly at this is due to the new Roblox Desktop update. Run studio as administator

I’ve had the desktop update for a decent while now, and my issues started like 3 days after this post, so I don’t think so
(assuming your talking about the roblox desktop app that you can disable by running roblox as an administrator)

Im also having this issue, every time I try to open the object browser, my roblox studio crashes! Its really annoying.

Whatever you do, do not do this at all. This will require Roblox Studio to always be run as administrator and won’t be able to open using the shortcut!

This is something I experimented with and I can confirm this is something to avoid.

@PoshKiwi I found out that opening Roblox Studio again after one is open allows both to not crash at all when opening the menus. It also keeps working if you close the second one. It had nothing to do with letting Roblox Studio sit. It seems to be a loading issue with assets from the looks of it and because a second one is opened, it allows the rest of the assets to be loaded into memory.

Edit: This is a consistent workaround. I did several tests doing this and it works! You have to let the first Roblox Studio crash while the other one is open and it should be all good to go. You’d have to do this every time you open Roblox Studio if it is not already open in a separate window.

Video on the fix:


My studio client was updated back to the version that crashes and the issue was reintroduced for me. I will have to try this! Thanks for the tip.

Please give us a stable version of Studio. Roblox team released this update prematurely and has caused numerous issues for numerous people…

1 Like

I just want to say that a possible temporary solution is to revert studio yourself. You can use this using CloneTrooper1019’s studio mod manager utility. You can force a certain version to be used (date based) which is really useful. This has worked for me until Roblox actually makes studio stable again.

1 Like

Using a 3rd-party application to allow for earlier versions is a solution, but using my weird method allows you to use the most recent version without the issues or 3rd-party apps.

Edit: The mod manager is not really a good idea if you want to be able to use the most recent features that the version of Roblox Studio that crashes provides, like the updated collision groups.

1 Like

Welp, the previous workaround doesn’t work for me anymore after an update, and now I can’t use Roblox Studio properly anymore. I am unsure if Roblox has this at a high priority right now and if Roblox even has a way to figure this issue out in any way possible.

1 Like

I don’t know if this is the same issue, but the new forced Roblox beta app also crashes just like Studio when I tried to go to messages in settings.

EDIT: I recently opened Roblox studio and it had an update. I DO NOT KNOW IF THIS FIXED THE ISSUE ABOVE OR THE CURRENT ONE.
Edit 2: Roblox beta app crashing is fixed, but one thing to note; when not in-game on the beta app, the cursor will freeze along with the fps. This doesn’t take place in the website-launched player. Roblox studio still has the same issue.

I never had the issue with the desktop app, but I can only assume it might be related to the same issue

well yeah. on my end the accounts launched from website and the one logged in on the app weren’t the same

I had this problem for over a week now, and just lost a bit of work to it, so I found this thread… updating my graphics driver to latest version via GeForce Experience and also updating Studio (did not test in-between) resolved it.

For what it’s worth, I’m on a Razer Blade 15 w/ RTX 3060 (Laptop); Windows 10

Thanks for the suggestions & solution that worked for me @PoshKiwi

(It also resolved Studio completely hanging without error upon closing the window, including Test Server/Clients)


My studio seems to have been reset to a previous version, and all issues seem to be fixed.


Thank you for the revert! Hopefully this issue can be fixed in the version with the latest icons. :grimacing:

1 Like

Dang, you’re lucky as I am on the latest version of my drivers (GTX 1660 Laptop) and I still have the issue :smiling_face_with_tear:

While experimenting with graphics modes, I found out that Direct3D11 is having issues. Swapping your graphics mode to anything else (recommend Vulkan since it looks visually the same as Direct3D11) and it should work just fine.

Thanks to @PoshKiwi and @ElephantMesh for taking the time to help out. Big preesh!

Edit: To change your graphics mode, you must go to File > Studio Settings > Rendering > Graphics Mode and change it from there. Thanks to @AborayStudios for mentioning this as I forgot to state it lol.


This works! For anyone who doesn’t know, go to File > Studio Settings > Rendering > Graphics Mode. Change to Vulkan then Restart Roblox Studio

One question, why do you recommend Vulkan?

1 Like

Unfortunately, studio updated for me (I assume back from the reverted version), and now I am not able to open studio at all (white screen error, as I experienced before.)

I made sure drivers are fully updated, and am still experiencing issues. If anyone knows a more permanent fix, I’d appreciate it.