Studio Design Refresh - Docking Overhaul & Ribbon Upgrade

Using the script editor has become just as laggy as many months ago when it (the editor) was revamped. The lag never happened on the older UI. This design refresh is terrible.

EDIT: Oh cool, even renaming items is a hassle!

1 Like

Somehow my properties window has become completely hidden and I am not able to open it.

Overall, this update is a good change, it just needs many improvements here and there.

1 Like

I’m having many of the same issues as others, such as my various windows not scaling properly or not appearing at all.

I also believe that this should be an “opt-in” feature. There are a lot of changes that are putting developers in their usual gait. Lots of developers(myself included) are also experiencing lag in studio. The icons are also just way too detailed for their size, it isn’t needed! I believe that the old icons were fine.

This update needs multiple changes.

Please make this opt in. It keeps RESHUFFLING my layout every time I open it. This is a very annoying loss in productivity because if I don’t fix it, I’ll inevitably click on the wrong thing, but fixing it takes time to do.

It also feels clunky and slow in comparison. The docking is just the worst change possible and there’s no way I can turn it off.

Furthermore, why is the UI Visibility button not one click away for people who work with the top bar minimized? This is such a stupid change because it was ALWAYS one click away which made working with UI much easier.


Please don’t force this change, like it’s not ready for release. It has performance issues as shown below which make working just a pain.

Version 545:

Version 546:

There’s a significant delay before I’m able to edit the script, and it only gets worse if you have more code.


What happened to the icons? Can I get the new ones back

1 Like

Hello developers,

Thank you all for your continued feedback on the Studio Design Refresh rollout. We are constantly listening and wanted to provide an update on a couple items - as of today:

  • We have released our new docking and ribbon behavior to all users. These changes give you additional flexibility and control over your workflow.
  • We have rolled back the new iconography and DPI awareness (these are linked). We are taking this opportunity to incorporate your feedback and will roll these back out later this year.

As always, thank you for your continued support as we improve our product and processes!


Can the iconography and DPI awareness get linked to a Beta feature instead? I enjoyed having high DPI support natively and was able to circumvent the iconography issue with @Elttob 's Vanilla 3 release.


Is it possible to enable this on my end? Using Studio as a high DPI user is almost not possible. Everything is hard to read, and clicking with precision on exactly what I want is near impossible.


I agree with him, while you guys are redoing that can you maybe take another look at booleans as the current style for them isn’t the greatest. Don’t get me wrong I love how they look now more modern my biggest issue with them is that strange little faint box around the edge of it make it seem like yall ripped a picture off google and slapped it in and called it a day.

I don’t mind when you hover over it that actually looks quite nice its the two little lines that are slightly offset I’m not a large fan over.



To add onto this, the greybox that appeared when selecting multiple objects that had the same property but different values disappeared as well.

1 Like

Also regarding checkboxes - why were the checkmarks made to be so dark and have no contrast against the background?


This makes it much harder to tell at a glance whether something is checked or not. A lot of other elements in Studio were given added contrast which is good, but checkboxes took a big step backward in this update.


Hey, i found a wierd bug. To reproduce i guess you have to pin the dock on below an move it rapidaly, it makes it literally dissapear.

I tried to reset view, restart the computer, but none of that worked, the widget affected here is output, if this is already a known bug and has a fix how do i fix it?

BTW the UI is amazing, cant wait to be confortable with it.

1 Like

Please upload a video or screenshot so we can better assist you

1 Like

Here, sorry if the image isnt very clever.

You see the output is on but the output is not anywhere (even below which is where it normally appears)


Try closing properties and explorer. It should re-appear.
If that does not work, you can do a full re-install and your layout will be reset.

Deleting the registery key might work too? Mentioning this one:


1 Like

Yes, that will also reset your layout.

All right, thank you for helping!

1 Like

Why when I open a script it opens just next to the explorer dock? I want it to open beside the game as it did before the update. And when I close all my docks gets re-dimensioned

The script dock seems to always open inside the most left dock. It takes too much space, I’m already using half the screen to see the game. The script should take the same space, while Im writing something in the script I dont need to see the game window. I have only one screen, I cant waste space.

There’s still a lot of work to be done here, at least on the MacOS side.

  1. The new docking system is still unstable, which causes Roblox Studio to crash after ~3 minutes of working with >1 widgets combined into one window in a float state. This, most likely, is repeatable with other scenarios as well.

  2. The new checkboxes on the ribbon and in the properties widget still look hideous and take more effort to figure out whether they have a checkbox or not.

  3. Pinning a widget or widget group seems to disable the ability for it to determine if the user’s cursor is hovering over a certain part of itself. This is most noticeable with the Toolbox where the icon doesn’t pop out when you hover your cursor over it.

  4. Combined widget windows still do not respect the minimum size of an individual widget while all widgets are visible. (I don’t have a screenshot because Roblox Studio crashes before I can take one)

I’ve only been using this new update for ~1hr and i’m already seeing a ton of serious bugs. I’ve defiantly noticed a lot of bugs I previously had be resolved but there are still so many to the point where I feel like I am using software in its early beta stages.