Studio Disconnecting

This has started to happen to me yesterday. I couldn’t get any work done due to Roblox disconnecting me after 15 seconds of me entering my game.

This issue has never occured to me before, despite the game being large in size.


Same here started happening to me and i couldn’t find any solution online.
Since i can’t sit around and wait i tried to solve the problem and after 2 hours of trying i managed to get it solved.
For anyone with this problem who’s disconnecting immediately after team create error message appears Try this :

  1. Press on Win + R and type %localappdata% then press Enter

  2. Locate the Roblox file and enter it.

  3. Go into ScriptAutosaves and Delete all folders in there

  4. Now open your game and see if the problem is fixed

Hope this fixes your problem. If it didn’t you’ll have to sacrifice some time and find a solution that works for you.
Note : If it wasn’t obvious already, this removes all script autosaves which i personally found useless because i have everything saved.

I’m sorry, but I’m afraid this is not related to this bug report. As I mentioned in my previous message, the problem persists even when trying to open the same file on another place with Team Create enabled. The issue described in this thread is causing the Team Create server to crash after a few minutes. Autosaves have nothing to do here.

i thought autosaves had nothing to do with this as well but removing them fixed the problem :man_shrugging:

It likely was caused by something else then. Neither of the affected place IDs can be found in my script autosave folder. I also believe autosaves aren’t loaded in that late for them to crash after that much amount of time (not to mention the fact that in this issue it’s the Team Create server disconnecting, and not Studio itself crashing). Sorry, but I still think you should try opening a separate thread for your issue.

The title is “Studio Disconnecting” and that’s exactly what happened to me and i decided to post a “POTENTIAL” fix if the root cause of the problem for anyone coming here is the same as mine.

I also tried a full reinstall of studio makings sure nothing was left behind and tried a studio install on a separate PC user account. The affected place still loads for a few seconds then disconnects.

Edit: Tried uploading a version from a backup to a new place the same thing happens

I am experiencing the same problem, not very sure but the problem started from yesterday when I was working with one of my developers. My internet is good, when disconnecting me it doesn’t show any errors or messages, it automatically logs on the place back.

UPD:when disconnecting this logo is appearing

1 Like

I’ve also been experiencing this problem few days ago and it kept happening when I try to join one specific place in Roblox Studio

And I only have time until next Saturday, so please get this fixed

I have started to experience this in Saturday 16th of September, and this issue only affects places with over 100K parts which have Team Create on. On smaller games, issue does not seem to happen.
And this is what I see every time Team Create disconnects me from large places.

Affected Place IDs: 7483404228 (Dev Place, unused), 5859982522.


Also having this problem, again a big build where all our assets are stored

螢幕擷取畫面 2023-09-21 182606
Well I have the same issue here. Sometimes i’m able to connect to the server, though whenever I press publish game then it loads for awhile(like 5mins frozen), sending the publish request, and suddenly jumps out and says connection lost to server(pic). When I press reconnect, it’ll never reconnect sucessfully and keep reconnecting forever like a loop(disconnect, auto reconnect, disconnect, auto reconnect…). But if I force quit studio and open it again, it loads up.

1 Like

Did not helped, I still experience this issue.

Cmoon Do somethingggg

It is unacceptable that TeamCreate disconnects without even finishing loading the game…

it happens in This Game

I need to update it and TeamCreate refuses to cooperate

and even worse: I download the RBXL to update it offline and “Publish to roblox as” works even worse, not even uploading the file at all

so it is impossible to develop on this platform

thank you.


I can agree with it, Team Create issue is a developer’s nightmare and we all hope for Roblox Staff to fix it.