Studio doesn't Select certain parts

When trying to drag and select parts in Roblox Studio, certain parts cannot be selected. They are not Locked.

As you can see in the GIF below, it will grab some parts, but not any under the model, “Map”. The parts it is grabbing has different parents/apart of different groups. It seems like it doesn’t know that the model, “Map” exists. Which unfortunately has the majority of parts i need to select.

I do not believe this started happening until recently (maybe even due to todays Studio update). But it was a Team Create place and I tried to download it locally to disable Team Create and the bug still happens.

Might be unrelated, but interestingly enough this also happened to me in the same Team Create place:

It completely overwrote a different place to it and the unions look all weird. Anyways, to clarify, it’s just this one place that is doing all of this. Selection works fine in all the other place files I’ve tested.

Beta Features enabled:

  • AI-Powered Code Completion
  • Face Capture
  • Live Animation Creator
  • Material Generator
  • Multi-Cursor Script Editing
  • Reconnect automatically to Team Create
  • Save rig with Animation
  • Scale factor for Models
  • Upgrade Shorelines

Related posts:

Expected behavior

The selection tool should grab all parts that are not locked.

A private message is associated with this bug report


Could you DM me a place file which demonstrates the problem? The whole place file in question or a reduced test case.

(Linking a place Id is not enough, engineers aren’t allowed to access arbitrary places)

I copied everything over to a new place and that fixed it.

1 Like

I just tried to ungroup the Model and then it lets me select the parts, but then it freezes Studio.

I tried doing the exact same box select which you did, and it selected the same items, but as far as I can tell those are the items which should have been selected. The things which weren’t selected are all things inside of another model whose center is far away from the grey box room you’re box selecting.

Box select by default selects toplevel parts and models whose centers are within the box selected region.

If you hold down Alt while box selecting, that will select individual parts instead, and you can see that all of the geometry within the room is selected.


i think you need to select over 50 percent of the build with your select box for it to work

1 Like

the selection works if you get the center of the module, you can have like 0% selected but if a small part goes through the center, it will be selected.
I am assuming this is the deel with your model being huge

1 Like

Yep, this was the solution. Thank you for taking the time to help me with this!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.