Studio FPS Dropping with Lua widgets open

Whenever I open a studio place that has the Drafts, Toolbox, or Terrain widgets open, studio drops to 12 FPS. I have disabled all beta features, disabled all plugins, have uninstalled and reinstalled many times, as well as updated my computer and it still happens. (Yes I even deleted all Roblox associated program files for one of them.)
The game just drops from 60FPS to 12FPS.

Where
Studio on any screen with a game open. I have tested this on multiple places with collaborative editing enabled. I have asked friends if they get this but they don’t.

When
It started happening 2 nights ago when I came home and opened studio after work.

https://youtu.be/vwEEO0FgSU4 (It kept failing to upload here.)

Steps to reproduce
Create a new place > Publish > Enable Team Create > Enable Collaborative Editing > Open Collaborative Editing Panel.
The place I used to test it

System Specs


Windows 10 Latest version (1909)

4 Likes

Did you try and see how your performances are and how much of them studio takes up, does your computer get slower after this or is it just in studio?

My computer takes no graphical or processing hits when studio does it, it’s only Roblox studio. I can still watch YouTube videos in HD, or Netflix.

Please make sure you are following How to post a Bug Report when reporting bugs. In this case:

And make sure VSync/GSync are not enabled for Studio.

Give me about, 1-2 hours because my upload speed at home is only 6Mb/s and it’s a 1.3 GB file.

Link to private DM containing DMP:
https://devforum.roblox.com/t/dmp-for-studio-fps-dropping-with-lua-widgets-open/472312

microprofile-20200302-124146.html (632.8 KB)

It looks like the GPU is taking a long time. Are you sure you have VSync/GSync disabled for Studio?

Where is the setting for v/gsync for studio? Because I went into the settings and was looking for it the other day when you said it, but couldn’t find it.

Update: Setting my graphics mode to OpenGL fixes the problem, when it’s on automatic it decreases the FPS with Drafts, toolbox, or game settings open.

Yep, that sounds like a VSync problem. To disable VSync:

  • Right click your desktop > NVidia Control Panel
  • Manage 3D Settings
  • Global Settings > Vertical Sync = Use the 3D application setting or Off instead of On or Fast

You can disable it for Studio specifically, but because the Studio executable changes path every version, you would need to do this every version if you do it per application.

It appears to be working after changing the Graphics Mode from Automatic to any specific one.

VSync was already off globally however.

Do you experience the performance problem again by setting Graphics Mode to Direct3D9 & 11?

Nope, I tried Vulkan as well, they are all working perfectly fine.

I just set it back to Automatic to see if it would happen again and it didn’t happen.