Studio gets slow and unresponsive when typing in Script Editor on Windows

Whenever I write in some scripts I press a button and it takes like a couple of seconds before the text actually appears, Studio stops responding sometimes and every time I open a new place it freezes at 28% for like 5-10 min. When it works it shows me some error that it could not fetch game settings and then the game loads.
I have never had these issues before, I started experiencing them when I started my computer some hours ago.
I have tried reinstalling, removing plugins and restarting my computer but nothing seems to help. I have deactivated beta features and reactivated and tested most stuff but it won’t work.

Some black box is also appearing sometimes, probably the box that shows you list of variables and functions just that it wont work correctly. I have also had issues a while back where when I wrote “Enu” and pressed enter for it to auto-fill, studio crashed. That bug fixed itself I think because I didn’t do anything to fix it.

All other programs work fine and work fine while Studio is not responding too. It’s not running out of CPU power or RAM as its not using much at all according to task manager.


(I was pressing buttons all the time in the GIF but it lags so much)

Specs:
Windows 10 1909 64bit
Intel Core I5 7400
16GB DDR4
GTX 1060

After further investigating I have discovered that it doesn’t matter how long the script is, what matters is how many variables there is. I will include a script with not that many variables but that still lags. It’s about 200 lines and about 20 variables. When I removed them it stopped lagging. Maybe something related to the autocomplete? But when I turn off autocomplete I still get the same issue. It’s really weird, and the script doesn’t have to be large at all as I first thought. I won’t include a place file as I would like to keep the stuff there private. But this happens in most places for me, when I inserted the script into an empty baseplate I didn’t experience anything. I could send the place file to an mod or something if you want.
Module.lua (6.1 KB)

This GIF is taken on my laptop with the same issues.

5 Likes

Would you please check your plugins as one may be doing something you are not aware of.

1 Like

If you undock the script editor widget (drag it out of Studio so the script editor is a floating window), does this still happen? Please also try disabling Gsync.

This may be the same issue?

I have disabled all plugins and beta features and tested that already, but thanks anyways :slight_smile: .

Undocking the script editor does not help and G-Sync is neither on or compatible with my system. :thinking:

Does disabling autocomplete under Studio’s settings (and all beta features) affect the problem?

As I said in the post it does not help to turn off autocomplete. :thinking:

I also have a laptop that I do everything on, all my plugins are trusted by the way. But rather my behavior consists of:

  1. Opening place in 3 minutes maybe,
  2. Start working on scripts,
  3. Gradually, as I keep working on scripts, the script editor keeps getting more and more slow and harder to use.

I experienced this behavior yesterday, while working on my game for 4 hours straight. I have 4 gigabytes of ram by the way. I can’t remember exactly what my specs are at the moment.

I also do not have ANY beta feature enabled as it uninstalls all my plugins for some odd reason.

1 Like

It is often difficult for us to understand why a slow down happens to some users but not to the others. If the irresponsiveness is long enough, a process sample/dump can help troubleshooting.

When your Studio stops repsonding, please try the following steps

  1. Start Windows Task Manager
  2. Right click the Studio process in the list, and pick “Create dump file” in the context menu
  3. Share the .DMP file with us
1 Like

Here’s the file, took forever to upload on DevForum so I had to upload it to Google Drive, file seems to be pretty big or something. Here is a private DM with the link: https://devforum.roblox.com/t/re-studio-gets-slow-and-unresponsive-when-typing-in-script-editor-on-windows/457399
Though today when I logged on I did not experience the issue where it told me team create error and that it got stuck at 20%, I’m guessing it was that update it did that fixed it? I did do a Windows update to the latest version yesterday, maybe that effected something. But the script editor is still broken.

I want to add on to this that after more time with the bug I think the problem is not the script variables or something like that, though they still effect the script when I remove them so I don’t really know what’s up with that. But, I started editing this reallly short script with like no variables and max 10 lines and it started lagging for no particular reason that I can think of. It’s kind of random I guess? This bug is making me really confused.

Whooho…
Now I am getting this error whenever I try to load a place, it opens it and doesn’t freeze at 28%. But when I join and it says “loading place” it gives me this error window:

Cannot load published place

Sorry, this published place could not be loaded.
Details: “HTTP 504 (Gateway Time-out)”

And for some reason the game icon for the place is fully black. Though this is only on one place, here is the link: https://www.roblox.com/games/4688408854/PlayerList-test
Should I make a new bug post about this or is it okay if I keep it here as it might be something related to my other issues, for a little while most stuff in studio has been unresponsive, laggy, glitchy and with a bunch of bugs and tons of crashes. It might be something with my computer, but why is my laptop also experiencing this issue :thinking:
I can play the place, in game the core gui and packages is erroring a bunch:


Something is totally broken, if it’s my computer, my Roblox installation or whatever I am not sure.

I am also getting errors for mesh handler http request stuff now, and some unions broke…

My friend is also experiencing the same published place error message, but for every place she tries to open
image

1 Like

I’ve been experiencing the exact same issue, has anyone found a solution yet?

Have been experiencing the same problem for a while now. Sometimes I get lag in the script editor, other times in the workspace window (camera and mouse movement is at 5 fps max)

To fix this I need to restart studio, but most of the time it comes back after sometime or when I use play test. If I then restart my PC I’m most of the time able to use studio without any problem for a few hours.