Studio Lighting is nothing like game lighting

Hello developers. I have a specific taste with lighting in games and I critique things very specifically, however, it is so annoying how changing lighting in the Studio editor is so incredibly different from playing in-game. What makes it worse is once you get the lighting set correctly inside the game, what it looks like in Studio is terrible, and it’s distracting from building. Does anybody else recognize this as an issue? Does anyone know why this is the way it is?


This isn’t an issue, this is a graphical thing, you’re probably on low graphic settings when compared to studio’s.


My graphic settings are fine, and I use Studio on multiple devices with different graphics settings and cards, the lighting never looks the same no matter what I change. May not be a problem for you but for me it’s annoying, impractical, time-consuming, and distracting.

Do you know of anything I could possibly change that I’m not thinking of to at least get it to look similar? Nowhere does it look similar to me, only default lighting.


I have never had, or seen this issue, and if anything, I would agree with @weakroblox35, it appears to be something on your end.


i play with lighting settings a lot, i tune a lot more then most developers would, and the more you fine tune game lighting the more the difference is. thats probably why im having a problem


Are you using level 21 in studio settings?


Like the others said they have never experienced this issue before. If you can send a pic how it looks like studio and how it actually looks. Make sure that this isn’t a game-exclusive problem (check if you also have this problem with other games. if you don’t then it might be something in your game. or it could be to different lighting things conflicting eachother confusing the system)


You’ll need to send screenshots for anyone to figure out what exactly the problem is here. We don’t know what’s going on.


I’ve been having the same issue. I swear that Level 1 in Studio and Graphics Level 1 on the client look nothinf alike - it’s as if Studio is an estimate. I don’t know if you’d have to use some sort of mod in Studio to fix it? Trying to help the best I can as I barely have any knowledge about this.


hmmmm, let me try that, i dont think i have.


i just took screenshots with level 21 on, and it helps a lot, im going to mark this as solution as it fixes the color differences, however the range of blur is still a little different, but a lot better.


@eeveelinknugget @Elttob @SKURMIEE here are the screen shots with level 21 render (as @absentdenik presented)

here is the default lighting in studio

here is the default lighting in game (perfect match)

here is a lighting project i made in studio

heres the same random lighting project shown in game. setting render to level 21 solves the issue with color (before in game looked way lighter) how ever the distance for blur seems a little closer especially zoomed out by higher render level makes it much closer.


I’m not sure but try using different rendering modes to fix blur. I’m not sure how to change it in studio, but roblox player needs FFlags:

"FFlagDebugGraphicsPreferD3D11FL10": "True"  --Direct3D 10
"FFlagDebugGraphicsPreferD3D11": "True"      --Direct3D 11
"FFlagRenderVulkanFixMinimizeWindow": "True" --Vulkan
"FFlagDebugGraphicsPreferOpenGL": "True"     --OpenGL

You can use Bloxstrap to easily change your FFlags


thanks i’ll try this very soon.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.