Studio performance when opening/playing games is much worse

After the first update of this year (Jan 6th?), I noticed Studio is now taking significantly longer to open and close places, and start and stop Play Solo sessions.

To illustrate, I have a play on remove sound in my game, and before the new year Studio would close before it could play even 0.5 seconds of it, now it takes studio so long to close that I often get to hear the whole 4.6 second sound and I’m still left waiting after it’s done. It takes a little over 33 seconds to close my game and return to the Studio home screen, a little over 28 seconds to load my game + a few more seconds for Studio to stop lagging, around 45 seconds to go from clicking play to spawning, and around 37 seconds to go from clicking stop to the game actually stopping (after I disable BindToClose in datastore code). I don’t have a time for how long it used to take, but I think it was less than half as long, ~10-15 seconds.

I do not notice issues like this when opening a blank baseplate and playing on it, I only notice it in complex places such as full games. I can provide my game file privately if that is helpful.

I want to say it’s also slower than normal to select/deselect instances in the explorer, but I’m less sure.

I also noticed that after starting a Play Solo session I get occasional mouse stutters accompanied with spikes in the microprofiler that consist of DeserializePacket > DeserializeItem labels, which come from streaming; these labels are pretty normal, but have never taken so long that they cause me significant mouse stutters.
Not sure if it’s helpful, but I’ll provide the dump for completeness. (1,4 MB)

I have tried disabling all beta features and the issue persists.

I’m not sure what else I can include that’s helpful towards proving this is real, nor finding the reason for this.
In general it just seems like performance about doing anything with the datamodel in Studio is worse than it used to be, since this is primarily noticeable when playing/stopping/opening/closing games.
This makes testing my game in Studio incredibly tedious.

I have not noticed any change with performance in live game servers. Studio just spontaneously had worse performance after the first update of the year.




I’m having the exact same issues, specifically with Play Solo. My studio has been taking a much more noticeably long time to start and stop my Play Solo session. This is fairly recent, as I had no issues over the break prior to this.


Me too! When I try to open one of my projects, it takes way longer than before, and with play solo session aswell! But it only happens in one of my projects, I tried opening other places and it doesn’t lag at all… It started 1-2 days ago :frowning:


I was having a similar issue with one of my games. It would take a long time to open the place or to stop Play Solo sessions, even on a local file. In fact, it would freeze Studio as if it was about to crash.
The same game uses FastCast, which takes advantage of Luau Type Checking. It’s the only thing in the game that uses the type checker. I noticed that when I opened some of its scripts, the same issue would happen when trying to close them or trying to erase the type checker annotation (at the top of the script). After I erased all the annotations, therefore disabling type checking, all the issues were gone. So I wonder if this could be related to the type checker somehow?


I began experiencing this issue as of the 6th of January. Some notes I noticed along side your observations:

  • Going INTO a test (i.e Play) does not generate any issues whatsoever.
  • When exiting the test, my CPU spikes (Image below)
  • This almost never affects empty baseplate like maps, only maps with decent amounts of content contained inside of it.

Steps I have attempted to resolve the issue:

  • Restarting Studio multiple times
  • Uninstalling Roblox Studio and clearing residual files (using IoBit Uninstaller)
  • Complete PC restart / shutdown

Based on what I have discovered so far, this an internal issue with studio and somewhat unrelated to the hardware being used as I have never experienced this issue prior.

My task manager while attempting to exit a test mode:

I hope this can be resolved soon as this makes developing in Roblox Studio nearly impossible since I cannot properly test my work :smiley:

1 Like

I also use FastCastRedux and can confirm, removing the type checkers seems to step on a land mine when trying to delete. My issue seems to be somewhat fixed so I do believe it has something to do with the type checkers although can’t confirm this entirely.

1 Like

Having the same problems, on a couple of my games, it will typically shoot robloxstudio into “not responding” for usually 10-ish seconds, or higher based on if the game has more content in it

1 Like

Update to @tomas7777’s initial observation:

  • This issue is centered mostly around type checking after further observation.
  • Attempting to delete type check lines causes studio to temporarily become unresponsive
  • The only way to remove them is by replacing them with whitespace (highlight then use space)
  • Attempting to delete any script that contains type checking using the explorer causes studio to become temporarily unresponsive
  • When attempting to remove the type check lines from FastCast Redux, Studio became unresponsive for up to 20 seconds.

This is the first time i’ve seen this happen within the script editor so I can’t definitively link it to type checks.

Not sure if the typechecker has anything to do with this issue. That seems like a different problem since inserting FastCast just freezes Studio outright. I have some code in my game that uses types and removing it does not resolve the problem.

1 Like

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.

Please note that filling a bug report does not guarantee that it will be fixed once triaged.


Thank you for you immediate response. We do appreciate it. :smiley:

I think this falls in line with a previous report I made, where I found a combination of type checking stuffs that just flat out nukes studio. Setting Table.__index = Table in this setup causes crash in strict type mode is where I reported it, tl;dr to get my place back and find the cause, I had to resort to reverse engineering my own save file. @PeZsmistic actually helped out in verifying this issue.

Seeing this potential for damage I do hope it gets fixed quickly, seeing that it makes editing places very difficult for those who want to deal in more modern standards of scripting.

The issue seems to have resolved for me around the time you posted. Performance is exactly the way it used to be.

@Mullets_Gavin do you see any improvement?


I see an improvement already. The repro file I used to isolate that crash no longer causes studio to hardlock, and it loads just like any other place file.

I also tried to open the original place prior to my manual modifications needed to isolate the problematic script, and it too no longer causes studio to hardlock, so it seems that the underlying issue has been resolved, at least from a look on the surface. This is good to see!


Performance has definitely returned to its original self. Loading/unloading into Play Solo sessions is no longer yielding, and I have no further performance issues.


Just opened ROBLOX Studio today and got this

  10:49:54.841  DataModel Loading  -  Studio
  10:49:57.555  Error while loading entities for universe 2268652935: HTTP 500 (Internal Server Error)  -  Studio
  10:49:57.556  Failed to load game assets, some Studio features have been disabled.  -  Studio

Not sure what to do about it sadly.


I experienced the issue too previously in the day, it seems to have been fixed for newly created places but when trying to open old places, especially when switching between different scripts from the script editor, studio becomes unresponsive for 10-20 seconds. Loading times are still high for me. From what I have noticed, this problem doesn’t seem to appear only for strict mode scripts but no check and non strict ones too. I have been unable to work due to this issue, hoping for it to be resolved completely soon.

1 Like
  17:09:03.545  Get symbolic links failed with error: InternalServerError  -  Studio

Have been getting this for a few days… But it still saves the game after error.

Opening projects is greeted with asset delivery errors. Same as above-mentioned by @BosOfroblox
Loading into Play Test is slower than usual, but not as slow as yesterday.

1 Like


Same here… Any solution already? :frowning:

1 Like

It has been really slow for me. Playing solo takes way longer to load in.