Studio resolution looks like is in 720p but i want it in 1080p

Hello my roblox studio looks quite off compared to others developers; I looks like I am in 720p on roblox studio but I am genuine that my PC resolution is 1920x1080p… Heres a screenshot of my roblox studio (the dark theme one) and other peoples studio ( light theme)

It happens when I launch any game on roblox studio (but not on roblox player) i’ve tried doing the Alt+Enter trick, it didn’t work, I don’t remember exactly when this happened but I suppose it’s when I downloaded it in March 2016 ( when I joined roblox) , I did verify if it was my OS limiting it (Windows 10) . It happens 100% of the time when i launch roblox studio and I really have no idea how this happened.

My PC Specs:
Hp Elitebook 840 G3
Intel Core i5 6300U
Intel Graphics 520
16GB RAM
256G SSD
Windows 10 pro 1903 Build
1920x1080p screen
Touchscreen 10 Points contact

Edit: oh and also my pc screen is 30.7cm x 17.3cm ( i don’t know if you can measure it like that)

6 Likes

Have you tried changing your graphics quality to max?

File > Settings > Rendering > QualityLevel > 21
File > Settings > Rendering > EditQualityLevel > 21

The quality level isn’t the issue here, Roblox doesn’t reduce the viewport’s resolution based on quality level.

I haven’t used windows in a while, but I think there’s a setting that allows you to make all the windows appear larger in the windows settings. You may have to take that slider and lower it so everything becomes smaller. If all your other windows look really big as well, this might be the solution

3 Likes

What happens if you make the window as large as possible? Any difference?

Personally I use 2 screens and put my Explorer, Properties, Output, Toolbox etc. on the other screen so I’m not even sure this is the issue.

The window in the screenshot is already full screen

Try closing the Output and other windows to see what that does, just for a minute.

The issue outlined below (under the “Details” dropdown) can be fixed manually.

Details

IMPORTANT NOTICE (2/6/2022): Due to Roblox recently pushing out updates attempting to fix the blurriness (for the past few months), the below method may not work. Recent updates have been fixing the blurriness but forcibly retaining the original scaling. If you just wanted a fix for the visuals, then Roblox is already pushing out updates for that. However, if you are still bothered by the scaling like myself, then unfortunately nothing works at the moment for the Roblox game client. It seems that this method still works for Studio.


In order to change the high DPI scaling setting of Roblox’s game client and/or studio client, you’ll need to access the game files. You can do this in two ways:

  • Copy and paste the following text into your File Explorer address bar: %LOCALAPPDATA%\Roblox\Versions
  • If you have a desktop shortcut for Roblox, you can navigate to it, right click on it, then click on Open file location

Once you’ve navigated to the “Versions” folder, you’ll need to find the RobloxPlayerBeta.exe or the RobloxStudioBeta.exe file depending on which client you want to change the scaling for. The version folder names aren’t indicative of whether it’s the player client or studio client so you’ll need to check each folder (at least to my knowledge; if it is indicative then it’s probably faster to quickly check anyways).

After you get to the client’s executable file, open it’s properties then head to the “Compatibility” tab. At the bottom you should see a button that says “Change high DPI settings”. Click on it.

Another window should have popped up after clicking the aforementioned button. Go to the bottom where it says “High DPI scaling override”. Check the box and set the scaling to be performed by “Application” if it isn’t already.

Note: After checking a few more posts regarding this topic, based on other user’s accounts, it seems that the “Application” setting isn’t the only definitive way of achieving the fix. I specifically listed Application because that’s the only setting that has worked for me but you can try other settings if it doesn’t work for you.

Once you’ve done that, you can click “OK” then “Apply” and you’re finished! This same process goes for Studio if you wish to change that as well.


Optional - Automate the process using a batch file (Credit: @AlreadyPro)

If you haven’t already noticed, each time Roblox is updated there is a new folder directory that is added for the new version, which means this process will have to be repeated manually each time there is a new update. Personally I’ve gotten used to doing it so it doesn’t bother me anymore, but it may for some people. If you wish to automate the process using a batch file program, you can do the following:

Details
  1. Create a new batch file with the file extension .bat
  2. Edit the file and paste the following code into the editor:
@echo off
set robloxDirectory="%LocalAppData%\Roblox\Versions"
set overrideScalingKey="HKCU\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers"
set overrideScalingData="~ HIGHDPIAWARE"

cd /d %robloxDirectory%

for /r %%f in (*.exe) do (
	call :AddOverrideScalingRegistry %%f
)

exit /b %ErrorLevel%
:AddOverrideScalingRegistry
reg add %overrideScalingKey% /v %~1 /t reg_sz /d %overrideScalingData% /f | echo %~1
exit /b 0

pause
  1. Save changes then you’re done. Run this file every time there’s a new update and you won’t have to manually change the high DPI scaling settings.

The code was directly taken from AlreadyPro’s original post which you can view here:

The above mentioned topic also seems to be the original post and active discussion regarding the issue. If you wish to stay updated, watch for new posts in that topic.


Causes

Originally I didn’t know why there seemed to be issues with scaling and to be honest I found the solution accidentally. The original cause of the problem seems to stem from your windows display settings. The “Scale” setting specifically seems to directly alter how the client looks, and if anyone is using a scale settings other than 100% they will have this issue.

As mentioned at the top of the post, Roblox is working to push out updates to fix the blurriness, but the scaling will be retained.


This post has been edited to provide more details and better explanation. You can view the original post here.

Original Version

I recommend changing the DPI settings of Roblox Studio. What you have to do is go to your local app data files and navigate to Roblox > Versions > then the most recent version. Or you can go to the shortcut on your desktop (if you have one) and right click on it then click open file location. Once you’re in the proper version folder, right click on RobloxStudioBeta/RobloxPlayerBeta then open up properties. After you open properties, go to Compatibility > Change high DPI settings > Override high DPI scaling behavior. After you check the override box, set the scaling to be performed by application. Then apply changes.

And you’re done! Open the roblox player or studio and it will be more scaled out to your screen’s resolution and look a lot better. Hope this works.

If you use this method you will also have to keep on changing the high DPI scaling behavior every time a new update is released. I’m used to this by now so I’m not bothered by it but just a little downside if you didn’t notice already.

24 Likes

If you press the small button with a phone and tablet icon in the top right corner of the viewport (above the player list and account name), then select HD 1080p from the drop down list, it will show a 1080p viewport in the space where the game is.

1 Like

Just realized that its not a Roblox thing, it’s a Windows setting, because the taskbar is also scaled, not just Roblox Studio. Open Settings, click System, then Scale and Layout to fix the scaling.

1 Like

Maybe Windows display scaling?

2 Likes

THANK YOU SO MUCH everyone that replied! I’ve haven’t all read the posts but thanks! And this is also my first time posting something so yeah, anyways i’m going to try each one!

Thanks it works! If i find an alternative i can tell you but for now i’m keeping this trick! Thanks!

1 Like

You can fix this issue by using the method outlined around here (that post and a couple above).

The flags you’ll want to set are those two at least. If correct GUI scale bothers you, also set "FFlagClientEnableHiDpi2" to false. However that will stop working when Roblox removes the legacy density-dependent pixel scaling for GUIs.

2 Likes

Thanks, I edited my post to include yours.

On a side note, I personally dislike the correct UI scaling and have grown accustomed to the smaller scale. Do you know if there’ll be any way to retain the smaller scale in the future?

As long as the FFlag exists, you can disable ClientEnableHiDpi2.

Also, you can set your scaling in Windows display settings to 100%.

We shouldn’t really be made to change a system-wide setting just to restore a behaviour that’s been commonplace and normal for years

The point is that, as I’ve said multiple times to multiple different people, the previous behavior is incorrect, and is now being corrected.

(bold emphasis mine)

1 Like

Then by all means, correct it but give people the option to continue with the current behaviour and force the Roblox application to 100% scaling, or even allow the DPI setting for Roblox itself to be set by the player. More options is a good thing!

Unfortunately that’s not how Roblox does things. For example the recent tostring changes. or Deferred Events.

I just noticed that I can’t change my resolution annymore, maybe that’s why i get more replies now lol