Studio scale misconfigured

Ever since the newest Studio update, the scale of my Studio went completely off. Everything is blurrier and bigger, and things are not getting resized correctly.
I have a laptop with an extremely high pixel density monitor.

album here

In the first image is a physical image of my thirteen inch monitor. The panels on the left and right are resized horizontally to the smallest possible configuration, which is still very wide. The second image is the actual screenshot, which shows everything as blurry, and shows extremely large pixels for the in-game. It’s almost as if I’m on an extremely low screen resolution.

Is this an issue for anyone else? Is there a configurable setting? Will it be fixed if it is not?

Right click on the desktop icon, Properties>Compatibility. In the settings box select “Disable display scaling on high DPI settings.”

4 Likes

This only works if you don’t directly open files. I really hope this is a bug instead of a feature as I don’t want to have to update the exe file every time there is a studio update.

1 Like

FWIW, you can step around this by dragging files onto the ROBLOX Studio icon. Not exactly the best solution but it’ll help for now.

So… this is a feature now?

What, the DPI scaling? I have no idea. I’m just suggesting a way that you can directly open files while still using the settings for the shortcut.

I think I will just stick with changing the exe compatibility mode instead of starting to drag over a desktop shortcut.