Studio scales incorrectly on high DPI monitors

So I just opened up Studio again recently and had to go through the rigmarole of overriding the high-DPI scaling as I usually do after every update. Except this time, Studio still isn’t scaling properly. The menus are huge, taking up screen space that they really don’t need to. I’ve tried setting the high DPI override to Application, System and System (Enhanced), all with no effect.


This is not useable.

As far as I can tell, Windows hasn’t updated between now and the last time I opened Studio (when it worked fine). GPU drivers have not been updated. I can only guess the latest Studio update has caused this. Running on a Lenovo Y50-70, 3840x2160 monitor. This problem should occur with any high-DPI monitor, if you wish to reproduce.


I’ve found several posts related to this using the search button at the top right;

Although your issue is slightly different, please don’t make another topic about it; instead, reply to/read through a topic similar to your issue. There’s the chance that it’s been solved before.


My bad, though search didn’t yield results for me (nor did the similar posts tab). If a mod could merge this post with another or lock it, that’d be cool.

EDIT: All those linked posts mention overriding or disabling high DPI scaling, which as I’ve stated no longer works.


I don’t know who flipped what switch, but the problem has been resolved with no additional work on my part. Thanks, Roblox team!


I was literally just about to post something like this. I’m glad it’s not just me that this is happening to.

1 Like

Any fix on this issue?
This month I started getting the same issue, where overriding DPI does not fix studio scaling issue, before when I override DPI studio scaled to how it should be, but now Its unusable. Even when I re-enable DPI studio is a little better, but still way too big and also becomes blurry.