Studio won't open, nor publish to my place

So, I was working on a Submarine Model. The Hull of the Model passed 10k triangles, but I reduced it to around 8,450 triangles. I did a bulk import of the model, in which as you would expect the Hull was rejected. I uploaded it after reduction and it worked.

I inserted the hull into the workspace, But I didn’t realize it was actually inserting, this means I inserted multiple hulls. I deleted the ones I didn’t need, and proceeded to put my mesh together. Studio crashed, and gave me a Team Create error which is weird because I’m 90% sure Team Create wasn’t enabled.

As of this time I cannot open the level. I opened an autosave and tried publishing that to the same level to overwrite what ever corruption occured but Roblox Studio refused to upload. At this point I’m locked out of my level.

Here’s a picture of the mesh.

This is a link to the place in question.

Do let me know if there are any issues with this post or you require more information.

Roblox is currently having a few issues including studio, although @Nightgaladeld just posted an update on the issues here. [ROBLOXCRITICAL] Users unable to access Roblox Games and Studio