Super laggy script editor on Mac - fixed


Been having this issue persistently on both my Macs, for maybe half a year now. I press a key on my keyboard, and it’ll take a significant amount of time before it’s reflected on my computer. If I press a lot of keys at once, it becomes far worse.

The size of the script doesn’t matter, it can literally be empty, scrolling is hugely laggy too. Having said that, the rest of studio works just fine.

My Macs are both fast and modern, both running macOS Sierra, 10.12.1
In terms of graphics card, on my MacBook Pro, I have a AMD Radeon Pro 450 2048MB as well as a Intel HD Graphics 530 1536MB. On my iMac I’m using an AMD Radeon R9 M395X 4096MB.

Both have plenty of free RAM and i7s. My friend GGGGG14 who recently brought a new Mac is having the same issue.

Edit: I have tried reinstalling multiple times and deleted the NP Plugin thing, and uninstalled all Roblox plugins.

ROBLOX In Game Pointer Error on Apple Computers

Whoever looks into this - it affects all the new macbooks in the office that I know of. Should be ez repro.


I have already submitted this internally. Hopefully we can get this fixed for you soon!


Any idea on when this might be fixed? It is currently making me tear my hair out lol.



I have no estimated time for when this will be fixed at the moment. I will update this post when I do.


Can we please fix this?
This is making development painfully annoying having either to suffer through typing at the speed of a snail, or having to copy and past from a separate text editor.
This should be on top of the to-do list for Roblox but it seems like they don’t care.


Been like this for so long too!

I’m fairly sure my desktop Mac has had it for a year but I could be wrong :confused:

But I guess it could be hard to fix


I understand that it could be hard to fix, but it’s been problematic for a while and it’s kind of crucial. If developers can’t develop as well or easily then in the long term ROBLOX will suffer.

I know this just seems like such a small minor inconvenience but it kinda chips away at the motivation to work on ROBLOX projects as apposed to something else.


This problem has got dramatically worse, almost to the point of unbearable on my laptop.


This was reported a month and a day ago, and it’s been a thing for a few months, and it’s unbelievably frustrating as it progressively gets worse.

Do you guys happen to have any idea as to when this will be fixed?


I’ve just pinged somebody about this but I am not sure when it’ll be fixed. Until then I advise using an external editor such as vscode.


Any updates on this bug that is hindering development for us?


It’s been nearly 50 days to fix a rlly bad bug that’s easily reproducible :confused:

I don’t like to nag but it means I can’t use studio at all pretty much on my desktop, and it means it’s super bad on my laptop. Using a 3rd party script editor, with it’s lack of intellisense is just intolerable as well, and it’s still difficult to copy and paste in correctly because of the lag when scroll.

Please please plleeeeeaaaaassssseeee fix <3


Hello! This bug brought a few other issues to our attention that dealt with the screen DPI and script window size. It is in progress and is high priority. We apologize for how long this is taking but we are working on it.



Really, if there is anything I can do to help please ask :smiley:



But I don’t want to thank to soon :wink:


Any updates? Can we help in anyway?


Still in progress and one of our highest priority items being worked on right now. We will let you know when the status of the ticket changes.

Known issue for Macbooks running macOS 10.12 (Sierra) and higher



It’s only been 4 days. They can work fast, but maybe not quite that fast for complex bugs. (especially because there was also a weekend in there somewhere :stuck_out_tongue:)