Surface appearance doesn't work in Roblox Client

Hello, I’ve recently been experiencing an issue in which surface appearance does not show up in normal Roblox, but works perfectly fine inside of Studio.
Like shown here:


I have no idea why this is happening, the textures aren’t deleted and they have been uploaded by me.

1 Like

It says it every time I make a change, I tried uploading different versions of the texture too, but still doesn’t work :frowning:
It appears Roblox is messing with my textures, they appear deleted but not deleted at the same time, as as for now roughness works but metalness doesn’t.

1 Like

Still nothing oof, I don’t know what’s happening with those textures, now roughness is gone too, thing is they aren’t deleted, I don’t know…

1 Like

Pretty plain and simple - PBR textures are still in beta features, which means that they won’t show up in game but will in studio.

Surface Appearance is fully released, but, I noticed that other people have had this problem too and that it is still not completely fixed :frowning:

My bad, I didn’t realise they finally released it : P

I found this on SurfaceAppearance, hopefully it helps because I have no idea

1 Like

Unfortunately, it says that every time, but doesn’t work yet, I have also tried changing the Id prefix to rbxassetID like other people suggested, but still nothing.

I’m seeing that the light reaching the mesh in studio is different from the one in roblox, maybe it could be affecting the texture?

1 Like

I doubt light has something to do with some image assets not loading in-game