Team Create Bugs. Post 'em Here!

Studio keeps crashing randomly when team create is enabled and it’s really annoying. It started happening yesterday, I am a Windows 10 with a low-end laptop user.

I am also experiencing this issue, starting recently.

Does your crash give some kind of error message or ‘not responding’ state, or does the program just suddenly terminate?

1 Like

No error message nor “Not Responding” state. It just closes itself instantly.

The same happens for me. I can’t think of anything that might trigger it - sometimes it’s when I press a button, sometimes I don’t do anything at all.

1 Like

Hi, @Dandystan and @02_t, just sent you guys about how to collect crash dump for the weird Studio crash cases, and please PM me the dump file once Studio crash again.

I am going out with my daughter, and will check them once got a chance:-)

2 Likes

Sure thing! Have a nice time with your daughter!

I HAD THIS ISSUE! I was creating a spectate function for a game, and I was publishing the game to test online with my alt, Actuus. After many frustrated hours, I finally figured out that Roblox Studio was not actually publishing my script changes while the script tab was open.

1 Like

I’m not really sure if this is a team create issue, But making changes to code, and going into play mode doesn’t execute the new changes. Though the changes are saved to the script. (I’ve been saving to roblox before restarting). However even after a restart seemingly my code doesn’t run. There isn’t any errors either.

Its simply like the code doesn’t exist. I have a script that loads all modules in a folder. However I started experiencing this really annoying bug, to the point I started wondering if my code simply doesn’t exist.

I put a new module inside of the folder to be loaded. That module also does not exist in PlayMode.

Using BindableEvents and BindableFunctions inside of Modules are also weird. To the point I started wondering if maybe the LocalScript to LocalScript, Script to Script, and ModuleScript to ModuleScript was a thing. Can I not fire a BindableEvent to a ServerScript from a ModuleScript?

Anyone has a wig? I’m gonna need more hair after this.

I know this is a bit late, but Team Create seems to be corrupting my places upon enabling it.
(Not group places)


It starts by pressing the button to enable Team Create. It enters an infinite “Loading game” popup, and upon pressing Cancel it becomes corrupted. Even when activated, the place says the permissions on the level prevent you from joining, and if you press Edit you’re stuck on the Loading game popup.

Hi, @marcoantoniosantos3
could you help confirm if your game is a new game created from BasePlate? I just noticed that new games created from BasePlate, after publishing & turning on team create, it cannot be opened now.

Yes, it is.

I opened a new place and tried to publish it there to clear what was previously there (since I no longer wanted it there), and it worked until I activated team create. So yeah, baseplate.

(EDIT: I moved the game to another place, which fixed the problem. Although, I am not sure why it didn’t work in the original game)

My friend is unable to join team create. Whenever he tries opening the place, it just says “loading game…” and has a cancel button. My friend uninstalled and installed studio multiple times and restarted his computer, too. I think this is some sort of bug.

(sorry for kind-of bumping this post)

The first “broken place” (now MaD Training Center) is fixed, but the “yet another broken place” isn’t.

Studio goes into an infinite loading screen when I turned on team create for a new game.
After waiting for awhile, I closed studio and clicked the edit button to see if reopening would fix, but it still goes into the infinite loading screen.

EDIT: Works fine if it’s not created from the empty baseplate template.

1 Like

Can confirm, same thing happened with me. Empty baseplate template caused issue, but village template did not.
image

1 Like

This should be fixed now. Thanks for the report!

3 Likes

We were making a place with my team. Whenever we union something, only the one who unioned can see the union. Others need to restart the studio to see it.

I came across this while developing on Team Create with my friend. He was making a map and unioned a few blocks together and, all of a sudden, they were gone on my screen but not on his. He removed the union, then I tried unioning it and it didn’t disappear on my screen but it did disappear on his.

When unioned, for the person that unioned it it looks like so:
image

But then for the other people it looks like so:
image

PS: Upon restarting studio, it appears for everyone, but I feel it is still necessary to report this.

1 Like

When my friend and I are using team create I can’t click the parts she added, and she can’t click the parts I added. We have to look in the explorer for them.

Could you provide more info?

How did you insert these parts?
What Instance type are they? (I know you mentioned Part, but this could still refer to several different types: Part, MeshPart, PartOperation,etc…)
If you leave and come back does the issue persist?