Team Create changes never saved - Lost Three Hours of progress

As of the past thirty minutes or so, studio decided to update while I was in my team create session (spontaneously). Since team create never prompts for a save, it closed without warning. When I went to reopen my place, I was surprised that the team create instance never saved and the building progress I’ve made in the past several hours was reverted to an old state.

During my team create session, my instance was stopped at five minute intervals telling me that it was autosaving. As I went to check my documents folder (mac user), I noticed that no saves exist.

I’ll pass down my anger and frustration in the hopes that there’s still a slight (even a minuscule) chance that my progress was saved somewhere and can be recovered. When a prompt tells me that it’s autosaving in a team create instance, I expect it to do just that. It’s disappointing and uneasily unfortunate that this doesn’t seem to work.

This is the version history of the place in question. I’ve tried to revert back to 71 & 70 with both being the same day old version.

I noticed this pop up in the output shortly after I reverted by game.

In addition, I’ve noticed that Team-Create doesn’t save when you revert your place back a version. This has some serious pitfalls. A solution would be to auto-save the file and overwrite the current saved file every time it’s saved. Should prevent the current clutter of multiple files.

Sometimes when you accidentally click the file -> New and your current version of studio doesn’t match with the most recent version of studio available, it’ll force quit all of your Studio instances. As mentioned above, Team Create doesn’t prompt for a save. Instead, I think it would be best if all current places you were editing are saved locally at the time it’s force quit as a safe-guard.

Place: AvatarTest - Roblox
Date: 11/20/19


Hi @sanjay2003, I’m investigating this case
for the link you’ve posted ( I see completely different version history from what you have mentioned… Could you verify if the place and version history are related? Is it possible you’ve been reverting a different place?
Also by any chance do you still have Studio logs available from that date?

@sanjay2003, after some analysis I can see that version history belongs to a different place:
could you verify which place did you have data loss issue with

Thanks for the response. I looked back at it. It appears that I sent the wrong screenshot which was totally my fault. I’ve included two screenshots from the actual place that lost data (AvatarTest - Roblox), the history after that might have been the other user who went to make a local copy. Past that, the history seems a bit weird. I went back in myself and re-uploaded what was saved to a new place (AvatarTest2 - Roblox) which seems to be working fine (I save locally quite frequently now).

As for the logs, I’ve compiled all of the .txt files from November 20th and included it in the .zip below. (forum wouldn’t let me upload a zip file)

@sanjay2003, Thanks for the logs, could you remember what time of the day did you have this issue happened? maybe what versions you tried to revert?

Anywhere from 3:50pm to 4:50pm (EST). I can’t remember the exact time.

Hi @sanjay2003,

I’m trying to reproduce the situation you’ve faced, but not sure exact place / version. You meant the place is, and what failed version to load after reverting is?

Version #172 to #184 . However, some of those saves might be overwrites from when I tried to revert.

I was investigating server log, and found that 3h sessions experienced problems saving changes at the server side
initial version was #188, and #189 and #190 were saved, but all following changes were missing

I figured as much. The other person building with me was on the most recent Studio update while I was not. Perhaps, the two studio versions were conflicting with each-other?

Perhaps, the two studio versions were conflicting with each-other?

I experienced something like this too, recently. I’m not sure if it’s on-topic but I figured it might help.

A different person in my team reverted a game to an earlier version. When I later opened that same game, the changes weren’t showing up in studio, for him they were and if you joined the game on roblox, the changes were there as well.

There seemed to be some sort of desync between versions. Please check this post.

1 Like