Teleports yielding indefinitely; places can't be opened. Places appear corrupted

Starting around 7:30 PM eastern, about 4 hours ago, users started reporting that teleports to specific places in my game universe started yielding indefinitely. The game uses one reserved server code for each place. This appears to have affected 4 out of 25 places. The teleport will initiate and nothing will happen for about exactly five minutes, then it will timeout with this message:

image

The places are created with AssetService:CreatePlaceAsync, and world state is saved with AssetService:SavePlaceAsync. As a developer, you can’t publish changes to these places, but you can go to the place on the website and open the files in studio. I’ve done this a couple of times for debugging.

This has always worked fine, but today the affected place IDs appear corrupted and cannot be opened. I get this error:

image

The affected place IDs are:

3823517626
3823358774
3823350323
3820145786

EDIT: I have reverted these places to earlier versions as advised in this announcement. I’m now able to open the places in studio again, but this has not solved the teleporting issue. The places are still inaccessible to my users, making the game completely softlocked if they attempt to travel to these places. For now I’ve made a wall that prevents them from traveling there.

7 Likes

I actually tried out my player lobby I made a while ago today, which teleports everyone in your party to their own server. It displayed this message, and I thought it had broken somehow, even though I haven’t touched it since it was working.

Can confirm the failed teleporting with 770 error code, but I can open the places with no issues. Affected place: 5079776632

2 Likes

Roblox is having some problems today; Roblox is currently having an outage.

Edit: Outage appears to have been fixed. Multiple posts have been reported saying place corruption is possible for other places. Sorry for my misunderstanding.

2 Likes