TeleportService:Teleport does not work the first time playing a game on console

A weird bug that I recently started encountering,

I have a gamemode select screen that prompts players to teleport to a different place within the same game universe, and it works perfectly fine for all platforms besides Xbox

On Xbox, after launching a new play session on the Xbox game app and playing my game, TeleportService is unresponsive. However, if I leave my game and then rejoin, TeleportService will start working as intended.

Error message on first Xbox first join attempt
The request is stalled indefinitely and never goes through (it only errors after I spam click the button, the code itself does not error)

The code (running in a LocalScript)


Same thing happens when I teleport from the server instead, removing the loop and pcalls still does not work and gives no errors

Noticed the bug happening here as well (join game -> join private island -> teleport request never goes through… rejoin, it works) I’m confident this is not an isolated incident with my game

I’ve noticed this happening as well (for quite awhile now). Thanks for reporting it :stuck_out_tongue:

Yeah Xbox teleporting is really broken. Sometimes if you teleport it doesn’t go through then you can’t rejoin the game because it attempts to load the place you tried to teleport to the last time you played which pretty much just breaks the app requiring you to restart it.

I just went on my Xbox and tried to teleport and both times they broke ROBLOX requiring me to restart the app just to get any games to work again. Can somebody please look into this? There are no errors or anything, the teleport goes through fine on PC.

I recently got an Xbox for Xmas, and I just discovered the woeful truth that is described in the OP is happening on my game as well.

I’ve run into this with my game as well. The first time I try to teleport, nothing happens, but rejoining and trying to teleport again works perfectly. I’ve also experienced the issue wravager mentioned where the teleport breaks in the middle of leaving/joining places, so that I am forced to close the app entirely.

I received word that the Xbox team is aware of the bug and is on it

Just started taking a look at this. I’ve identified what the issue is and working on a fix. Note that Xbox releases are a week behind desktop, but will be targeting our 368 release which for Xbox will be in a few weeks.

Thanks for bringing this up, was a really sneaky bug.



Oof, I really wish xbox updates were quicker, 90% of the players on my game cannot join a match because they never teleport. I’ll get matched in a 5v5 and it will only teleport me to the ReservedServer even when using TeleportToPrivateServer.

I enabled the fix for this today. About 25% of Xbox users are still on version 367 and will not have the fix until we force update, which will happen today at around 4PM PST.

Thanks again for your patience, and for reporting this to us!


Thanks for the fix! I can finally advertise for Xbox again without worrying about all the new players not being able to join a match.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.