Terrain doesn't render / load

I made a smooth terrain map for my game with no landscapes or mountains but the terrain never fully loads.

This is intended. If you increase your graphics quality, it’ll render more terrain. Unfortunately, this is something you just have to deal with.


How to increase my graphics quality?

1 Like

In game, you press F10 on the keyboard or press escape, switch graphics quality to manual, and adjust in the settings menu.

In studio, I don’t know. Just Google it.

Important to note: Graphics quality is set by each player individually, so remember to check your game on multiple graphics levels. I recommend checking on levels 1, 4, 6, 8, and 10 in particular because they each have somewhat unique rendering in my experience.

Might be because of your pc’s specs

1 Like

At the top left of Studio there is a File tab, click it, go to Studio Settings and look for Graphics settings in the tabs shown.
Are you Playing in both pictures, or is it just in Studio mode?

In the game viewer in Roblox Studio, to change the game’s graphics, it’s the same as the Roblox Player. You can change the quality by hitting Esc or pressing the Roblox icon in the top left corner and following these steps:

(during playing in studio only)

Also, there is an option in Studio Settings to render the game (not playing):

FILE > Studio Settings > Rendering

Here you’ll see a bunch of settings to edit the quality

1 Like