Text is appearing blurry on Surface GUI

Believe that’s because you have it scaled the text in a weird way, or it just looks scaled improperly.

Try re-scaling the text and it should be better.

1 Like

That is probably because your canvas size is off, or you scaled the textlabel off.


No dude. It still didn’t work. I’ll try to redo all the things tommorow.
Still Thanks for the help

1 Like

Try using ‘PixelsPerStud’ in the surface gui menu, instead of the ‘FixedCanvasSize’ option. That would make it scale properly!


Didn’t worked :frowning: .

You posted the same screenshot twice.
To help you further, can you send a rbxm file with the model? Then I will investigate it for you (and ofcourse explain how to fix it!)

1 Like

Sure I’ll do it soon. In a few hours.

board.rbxm (6.1 KB)
Never mind Here it is.

Maybe try:

Going to the surface gui, make sure that AlwaysOnTop is set to true.
Making the TextStroke transparency to 1.
Try going to the surfacegui and change the sizing.
Or, try changing the SizingMode to PixelsPerStud. (in the surfacegui)

— If it does not work, reply to this message. –


Well I Followed your steps and the result is same. Here have a look
text3 done text text2

after scaling the text

SurfaceGuis have a property called pixels per stud. The higher that is, the higher res it will be. The lower it is, the lower res it will be.


But how do I drag it to the bottom of the part? I’m confused. It’s one of my first time making GUI And don’t really know about pixelperstud . I changed it to 15 . But it’s spreading to right side but I want it to go down and cover the part

UDim2 has 4 variables: X Scale, X offset, Y scale, Y offset.

Offset are size in pixels, and scale is based on the objects size.

A scale of 0 is nothing, and 1 is the entire length. An offset if 100 would be 10 pixels high.

To make it stretch the whole part, set the size to 1,0,1,0.


Can set it to way higher than 15. Maybe try 1000 and then lower it again until you find something that you like.

For performance you prob want it as low as possible, but as high as you need it for the look you want.

Worked but the text got smaller and smaller

I partly forgot that I answered your question, but here comes my solution. First my result:

Left my gui, right yours.

What I did was:

  1. Setting every GUI to PixelPerStud (the version gui with 20 pps, the outlined section 30 pps)
  2. Using scale instead of offset
  3. Line out the textlabels.

Here is my version:
myboard.rbxm (6,1 KB)
If you have any questions, don’t hesitate to ask!


How do you calculate the pps for a brick?

You don’t really have to calculate. How higher the pps is, how smaller the text will be. So I usually just try it out (with trial and error)

1 Like

Thanks! @Boele009

Your text brick resizes the text automatically whilst keeping it sharp. My pixelated surface GUI issue is no more, thank you!