Trying to drag one end of a part. Then the other end starts moving

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? - Moving an object without the other end moving too.

  2. What is the issue? - When I try and drag one end of a part, then other end starts moving.

  3. What solutions have you tried so far? - I have looked on the DevHub and found nothing.

1 Like

Your description is a little vague here; are you using two parts that are connected using a weld or some other connective instance? Or are you attempting to do this using only one part?

Do you have any other details that can help us reach a solution?

Well basically what’s going on is; I press the; “Part” button in toolbox. Then try and drag one end of it. Then the other end starts moving at the same time. I have no idea what is going on.

Are you attempting to resize the part?

Yes. And the other end is moving when I do so. I am only trying to resize one end of the part, then the other end randomly starts moving.

Make sure to click on the Scale button when resizing the part, which can be found under the Model ribbon. (See below.)


When you scale, make sure to click on the spheres that indicate which dimensions you want to increase/ decrease.


Please note that this is not the correct area to post this question. I believe this post would be suitable for #development-support:building-support. Please read the forum rules before you post.

Fixed, anyways. I have tried the solution, and it is not working. Thoughts?

Have you selected the part you wanted to rescale? Just click on the part and you should be good to go :+1:

I have. Then I try and rescale it. Then one end of the part moves, then the other end starts moving too.

What do you mean by “the other end of the part moves”. Can you share a video of the behaviour?

Currently I can not, as I do not know how too. Anyways what’s happening is when I try and rescale the part I only want one end of it to move. The other end randomly starts to move when I try and rescale one end.

Use Gyazo to record a gif of the behaviour you are describing.

Is the part a uniform cuboid part, or is it a union or otherwise more complex part?

It’s just a normal part. I click the “Part” button to get a part and it’s doing that.

You’re going to have to share a video or gif of what you’re describing, otherwise it’s very hard to help you.

I- Physically can’t, truly I’m not allowed to download anything on my computer, but Roblox… But what I’m saying is, when I try and rescale one end of the part, the other end starts rescaling itself too.

Repeating your description of the problem does not give us any more information to work with

I’m not sure what other detail to give. It’s just that, there’s no details too it…

Are you holding CTRL when resizing? That will scale your part from its center rather than from its edge.
Not holding CTRL (only left click)

Holding CTRL + left click

This is the only thing I can think of, unless your game is using some sort of plugin you’re unaware of. We really can’t help more without some more context from you.

1 Like

The only other possible reason for this is that the Part in question is over 2048 studs long, in which case it will not resize any further and instead treat anything more than the max as a Drag action:

Additionally, if you’re on a PC, type in the search bar Snipping Tool so you can quickly and easily take screen shots. It’s default on all Windows PCs so you won’t have to download anything, so there’s no reason not to use it.


Alright I will do that very soon and show you my problem.