Unable to open Roblox Studio on MacOs

Issue should have been resolved.
If you have gotten into this bad state, you will need to reinstall Studio from the website.
If that does not work please reply below.


try turning off the anti-virus, or a simple restart could fix the thing.

1 Like

Just reinstalled Studio from the website again - same issue.

1 Like

@Fondatix Did you use Studio at all today/yesterday and have it working?
When you install from the website are you downloading a .dmg and that is failing to launch studio after it reinstalls?

Yes, yesterday Studio got the new icons and docking update and was functioning fine for the entire day, although with a big performance hit due to the update.

I’m not sure what you mean by the second question. If you are asking whether or not the installer is failing to load then no, Studio installs seemingly fine, it is only after it has installed and I try to launch Studio that the error occurs.

and you are sure you are launching the newly installed studio, and not your old one?

1 Like

Yes, before reinstalling I made sure to delete the Studio from the applications folder.

1 Like

If you run this command in your browser url, what is the result displayed on the webpage.

e.g. {“channelName”:“LIVE”}


If you Install Studio from an incognito window so you are not logged in, do you experience the same issue?

Just tried it, this did not fix the issue.

I am having the same problem, yesterday studio was working perfectly fine, besides the huge update where performance was a little different and visual changes, which were to be expected. So I was stoke to see a new update when I tried opening studio today, but after updating, whenever I click on studio it just bounces one time and it doesn’t even open, there’s no error, no failed message, nothing, not even a white dot underneath the logo. Roblox is working perfectly fine though, just not Roblox Studio.

1 Like

Experience the same issue after updating. Uninstalling and installing Roblox studio does not seem to solve the problem. Tried also installing an older version the result is the same.

1 Like

Same here… I think the latest update messed up things during the installation.

1 Like

Our build team pushed another fix. A Reinstall should now hopefully fix the issue, although you will likely be prompted to update back to the non-modern studio.


Just reinstalled Studio and it’s now working. Thanks!

While I am not on MacOs, Studio is not working. No errors, just a white, frozen screen.

This bug is also mentioned on this topic:

This is happening to me too, and I’m on Windows 11.

1 Like

I have successfully found a workaround.

For me, whenever I tried to open studio, just a white screen came up. What I had to do was uninstall studio, then reinstall. Since studio works the first time after reinstalling (but not after), I Immediately opened an empty place, and changed the studio graphics setting to Vulkan.

So far, this has fixed it. I appreciate the tip, @hunterk1241. For those not able to access studio, this should be a good workaround for now. This error does need to be fixed though.

Setting studio to Vulkan, unfortunately, didn’t manage to fully fix the problem.

If anyone has any questions, I would appreciate it.

@PoshKiwi So im having a similar issue on my MacOS machine: My Roblox Studio allows me to login and view my experiences, now whenever I try and open an experience that contains an active team create, it gives me this error message and doesn’t allow me to join.

It is worth noting that I have tried restarting both my computer and RS. These have not solved the issue.

EDIT: I have done a clean reinstall of the program from the website and I am still having this problem.

Error Message:

MacOS Model:

I add this post to this thread because this has never happened on my primary Windows machine, but only on my MacOS machine.

1 Like