Unable to open specific Team Create places

Since around March 11th, I have been unable to open specific group-owned Team Create places (1538358704 and 3389659398). Since yesterday it stays on the “Loading game (attempt XX)” screen for hours, before giving me this error:

This incident occurred just now after it went up to around attempt #100 after 2 hours of clicking on the place.
This topic is similar to this one where it states that this issue should be resolved since a few hours ago, but it still keeps on occurring for me.

I had that issue the other day, and now none of my places within my main game that normally show up in Studios asset manager are showing at all. Says “No Places Found” yet on the website they still exist.

Thanks for the report. We think the issue should now be resolved. Can you confirm?


It seems to be fixed now. I do think some people may have lost work done in studio leading up to this issue. My Team did work in a studio place on monday, then had the “No Places Found” problem on tuesday. We found that we lost the work we did on monday once the issue was fixed and we could access the place again. I’m guessing the auto save was failing as a side effect of this issue.

It appears it’s still happening for me, been loading for over half an hour:

The issue is resolved now, thank you!

1 Like

Hey @bluestann, I’m experiencing this issue again since around 10 hours ago (might have started before that, but I didn’t try to load the place yesterday)


Hey there, seems to be a problem for me too. Any way I can fix this?

These should now be resolved. Please note that these errors could be due to various causes. Please check the roblox status page for the most updated status.

1 Like

I’m being affected by this too.

Place ID: 6343634037
Incident ID: 2318677486529699606
Request status code 2, connection result 4.

Started happening today (Worked fine yesterday).

Windows 10 pro x64 latest updates.

This is happening w/the majority of my places now, not just a specific one.


As many others above have already reported, I too am having major problems with this. My friend, Alex (TwentyTwoPilots) has suggested a work around trick as he’s been having this same issue as well however it’s rather annoying having to do this every time I need to join a certain place and it always seems to be the place that I need in the most. The work around trick is to join at least 2 different places that are running team create as well. Then when rejoining the place that’s bugged, it usually loads you in. Prior to him suggesting this work around for me, it used to take at least an hour of trying to join the place for it to finally load me into it. Please fix this asap, thanks. :slight_smile:

Note: This error has been around for a little more than a week now since it first surfaced.

This is not resolved for my either. Most of my team create places are broken at this time, rarely allowing me in, and if they work, it takes a long time.

There is no reason to believe this isn’t related to the original issue, I only started seeing this issue when the others did as well. When I’m back at my computer I’ll go ahead and put the place IDs.

This issue is not resolved for me, same thing is happening constantly.

Could you try connecting to your mobile phone’s cellular network and then opening the place? I want to rule out any wifi ISP problems.

1 Like

I just tried on my cellular network, it loaded only twice after many attempts over the past 12 hours.

I am still having this issue.
When is there going to be a fix?


1 Like

Hey @bluestann, I just noticed something. I haven’t been able to play Roblox games since the 27th , at first I assumed it was an issue with the place I was trying to play and ignored it as I was able to play on the 25th.

However, just now I tried playing Adopt Me! and a few other games to test this. My ping hovers around the usual 250 ms for a few seconds after joining, but immediately spikes up to huge numbers such as 17,000 ms, which leads to me getting disconnected shortly after.

I’m able to play non-Roblox online games just fine.

Furthermore, I’m able to publish local files to published places (although I haven’t tried publishing to a Team Create place yet)

There are a few issues being discussed here. If you are still having issues connecting to a Team Create place, please direct message me the Incident ID or an image of the error you are receiving.

Also, please update to the latest version of Studio first

This issue should now be resolved! If this issue is still occurring, please create a new topic for us to look into.

1 Like